Netmaker vulnerable to Insufficient Granularity of Access Control
CVE-2022-36110GHSA-ggf6-638m-vqmg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/gravitl/netmaker 0.15.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/gravitl/netmaker
- Affected
- < 0.15.1
- Fixed in
- 0.15.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-ggf6-638m-vqmg lists affected ranges: Go github.com/gravitl/netmaker >=0 <0.15.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-36110: 0.90% estimated exploitation activity in the next 30 days; percentile 59.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Improper Authorization functions leads to non-privileged users running privileged API calls. If you have added users to your Netmaker platform who whould not have admin privileges, they could use their auth token to run admin-level functions via the API. In addition, differing response codes based on function calls allowed non-users to potentially brute force the determination of names of networks on the system. Patches This problem has been patched in v0.15.1. To apply: 1. docker-compose down 2. docker pull gravitl/netmaker:v0.15.1 3. docker-compose up -d For more information If you have any questions or comments about this advisory: Email us at info@netmaker.io This vulnerability was brought to our attention by @tweidinger
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-ggf6-638m-vqmg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-36110 Advisory: Netmaker vulnerable to Insufficient Granularity of Access Control IDs: CVE-2022-36110, GHSA-ggf6-638m-vqmg Record: https://patchnext.com/advisories/cve-2022-36110 (revision 1, source checked 26 Oct 2026, 14:58 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/gravitl/netmaker 0.15.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/gravitl/netmaker: affected < 0.15.1; fixed in 0.15.1 ## Suggested inspection (read-only) - Go github.com/gravitl/netmaker: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/gravitl/netmaker. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-ggf6-638m-vqmg (GitHub-reviewed advisory GHSA-ggf6-638m-vqmg lists affected ranges: Go github.com/gravitl/netmaker >=0 <0.15.1) Commands are suggestions: review each one before running it.
Loading voting…