Skip to content

← Actionable
Medium, CVSS 5.3

Docker supplementary group permissions not set up properly, allowing attackers to bypass primary group restrictions

CVE-2022-36109GHSA-rc4r-wh2q-q6c4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/docker/docker 20.10.18), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
EPSS
  • CVE-2022-36109: 1.05% estimated exploitation activity in the next 30 days; percentile 64.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Moby is an open-source project created by Docker to enable software containerization. A bug was found in Moby (Docker Engine) where supplementary groups are not set up properly. If an attacker has direct access to a container and manipulates their supplementary group access, they may be able to use supplementary group access to bypass primary group restrictions in some cases, potentially gaining access to sensitive information or gaining the ability to execute code in that container. This bug is fixed in Moby (Docker Engine) 20.10.18. Users should update to this version when it is available. Running containers should be stopped and restarted for the permissions to be fixed. For users unable to upgrade, this problem can be worked around by not using the "USER $USERNAME" Dockerfile instruction. Instead by calling ENTRYPOINT ["su", "-", "user"] the supplementary groups will be set up properly. Thanks to Steven Murdoch for reporting this issue. ---- Impact If an attacker has direct…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-rc4r-wh2q-q6c4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-36109

Advisory: Docker supplementary group permissions not set up properly, allowing attackers to bypass primary group restrictions
IDs: CVE-2022-36109, GHSA-rc4r-wh2q-q6c4
Record: https://patchnext.com/advisories/cve-2022-36109 (revision 1, source checked 26 Oct 2026, 15:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/docker/docker 20.10.18. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/docker/docker: affected < 20.10.18; fixed in 20.10.18

## Suggested inspection (read-only)
- Go github.com/docker/docker: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/docker/docker.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rc4r-wh2q-q6c4 (GitHub-reviewed advisory GHSA-rc4r-wh2q-q6c4 lists affected ranges: Go github.com/docker/docker >=0 <20.10.18)

Commands are suggestions: review each one before running it.

Loading voting…