Shopware access control list bypassed via crafted specific URLs
CVE-2022-36102GHSA-qc43-pgwq-3q2q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (shopware/shopware 5.7.15), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist shopware/shopware
- Affected
- <= 5.7.14
- Fixed in
- 5.7.15
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qc43-pgwq-3q2q lists affected ranges: Packagist shopware/shopware >=0 <=5.7.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- EPSS
- CVE-2022-36102: 0.80% estimated exploitation activity in the next 30 days; percentile 56.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact If backend admin controllers are called with a certain notation, the ACL could be bypassed. Users could execute actions, which they are normally not able to do. Patches We recommend updating to the current version 5.7.15. You can get the update to 5.7.15 regularly via the Auto-Updater or directly via the download overview. https://www.shopware.com/en/changelog-sw5/#5-7-15 For older versions you can use the Security Plugin: https://store.shopware.com/en/swag575294366635f/shopware-security-plugin.html References https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-09-2022
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qc43-pgwq-3q2q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-36102 Advisory: Shopware access control list bypassed via crafted specific URLs IDs: CVE-2022-36102, GHSA-qc43-pgwq-3q2q Record: https://patchnext.com/advisories/cve-2022-36102 (revision 1, source checked 26 Oct 2026, 13:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: shopware/shopware 5.7.15. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist shopware/shopware: affected <= 5.7.14; fixed in 5.7.15 ## Suggested inspection (read-only) - Packagist shopware/shopware: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on shopware/shopware. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qc43-pgwq-3q2q (GitHub-reviewed advisory GHSA-qc43-pgwq-3q2q lists affected ranges: Packagist shopware/shopware >=0 <=5.7.14) Commands are suggestions: review each one before running it.
Loading voting…