Skip to content

← Actionable
Medium, CVSS 6.9amended

OAuthLib vulnerable to DoS when attacker provides malicious IPV6 URI

CVE-2022-36087GHSA-3pgj-pg6c-r5p7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (oauthlib 3.2.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI oauthlib

    Affected
    >= 3.1.1, < 3.2.2
    Fixed in
    3.2.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2022-36087: 1.78% estimated exploitation activity in the next 30 days; percentile 78.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact - Attacker providing malicious redirect uri can cause DoS to oauthlib's web application. - Attacker can also leverage usage of urivalidate functions depending where it is used. What kind of vulnerability is it? Who is impacted? Oauthlib applications using OAuth2.0 provider support or use directly urivalidate function. Patches Has the problem been patched? What versions should users upgrade to? Issue fixed in 3.2.2 release. Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? The redirecturi can be verified in web toolkit (i.e bottle-oauthlib, django-oauth-toolkit, ...) before oauthlib is called. A sample check if : is present to reject the request can prevent the DoS, assuming no port or IPv6 is fundamentally required. References Attack Vector: - Attacker providing malicious redirect uri: https://github.com/oauthlib/oauthlib/blob/d4bafd9f1d0eba3766e933b1ac598cbbf37b8914/oauthlib/oauth2/rfc6749/granttypes/base.py#L232 - Vulnerable…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-3pgj-pg6c-r5p7

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-3pgj-pg6c-r5p7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-36087

Advisory: OAuthLib vulnerable to DoS when attacker provides malicious IPV6 URI
IDs: CVE-2022-36087, GHSA-3pgj-pg6c-r5p7
Record: https://patchnext.com/advisories/cve-2022-36087 (revision 3, source checked 26 Oct 2026, 13:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: oauthlib 3.2.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI oauthlib: affected >= 3.1.1, < 3.2.2; fixed in 3.2.2

## Suggested inspection (read-only)
- `python -m pip show oauthlib`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on oauthlib.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3pgj-pg6c-r5p7 (OSV record GHSA-3pgj-pg6c-r5p7 lists affected ranges: PyPI oauthlib >=3.1.1 <3.2.2 (fixed))
- Verified: https://github.com/advisories/GHSA-3pgj-pg6c-r5p7 (GitHub-reviewed advisory GHSA-3pgj-pg6c-r5p7 lists affected ranges: PyPI oauthlib >=3.1.1 <3.2.2)

Commands are suggestions: review each one before running it.

Loading voting…