linked_list_allocator vulnerable to out-of-bound writes on Heap initialization and Heap::extend
CVE-2022-36086GHSA-xg8p-34w2-j49j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (linked_list_allocator 0.10.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io linked_list_allocator
- Affected
- <= 0.10.1
- Fixed in
- 0.10.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xg8p-34w2-j49j lists affected ranges: crates.io linked_list_allocator >=0 <=0.10.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.4 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-36086: 0.88% estimated exploitation activity in the next 30 days; percentile 59.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact What kind of vulnerability is it? Who is impacted? This vulnerability impacts all the initialization functions on the Heap and LockedHeap types, including Heap::new, Heap::init, Heap::initfromslice, and LockedHeap::new. It also affects multiple uses of the Heap::extend method. Initialization Functions The heap initialization methods were missing a minimum size check for the given heap size argument. This could lead to out-of-bound writes when a heap was initialized with a size smaller than 3 sizeof::<usize because of metadata write operations. Heap::extend This vulnerability impacts three specific uses of the Heap::extend method: - When calling Heap::extend with a size smaller than two usizes (e.g., 16 on x8664), the size was erroneously rounded up to the minimum size, which could result in an out-of-bounds write. - Calling Heap::extend on an empty heap tried to construct a heap starting at address 0, which is also an out-of-bounds write. - One specific way to trigger this…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xg8p-34w2-j49j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-36086 Advisory: linked_list_allocator vulnerable to out-of-bound writes on `Heap` initialization and `Heap::extend` IDs: CVE-2022-36086, GHSA-xg8p-34w2-j49j Record: https://patchnext.com/advisories/cve-2022-36086 (revision 1, source checked 26 Oct 2026, 15:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: linked_list_allocator 0.10.2. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io linked_list_allocator: affected <= 0.10.1; fixed in 0.10.2 ## Suggested inspection (read-only) - crates.io linked_list_allocator: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on linked_list_allocator. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xg8p-34w2-j49j (GitHub-reviewed advisory GHSA-xg8p-34w2-j49j lists affected ranges: crates.io linked_list_allocator >=0 <=0.10.1) Commands are suggestions: review each one before running it.
Loading voting…