Skip to content

← Actionable
High, CVSS 8.6amended

Parse Server vulnerable to brute force guessing of user sensitive data via search patterns

CVE-2022-36079GHSA-2m6g-crv8-p3c6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 5.2.5, 4.10.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm parse-server

    Affected
    < 4.10.14>= 5.0.0, < 5.2.5
    Fixed in
    5.2.5, 4.10.14

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2022-36079: 1.28% estimated exploitation activity in the next 30 days; percentile 70.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Internal fields (keys used internally by Parse Server, prefixed by ) and protected fields (user defined) can be used as query constraints. Internal and protected fields are removed by Parse Server from query results and are only returned to the client using a valid master key. However, using query constraints, these fields can be guessed by enumerating until Parse Server returns a response object. Patches The patch requires the master key to use internal and protected fields as query constraints. Workarounds Implement a Parse Cloud Trigger beforeFind and manually remove the query constraints, such as: References - https://github.com/parse-community/parse-server/security/advisories/GHSA-2m6g-crv8-p3c6

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2m6g-crv8-p3c6

  2. Revision 1 · created ·

    Published from osv record GHSA-2m6g-crv8-p3c6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-36079

Advisory: Parse Server vulnerable to brute force guessing of user sensitive data via search patterns
IDs: CVE-2022-36079, GHSA-2m6g-crv8-p3c6
Record: https://patchnext.com/advisories/cve-2022-36079 (revision 2, source checked 26 Oct 2026, 12:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: parse-server 5.2.5, 4.10.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm parse-server: affected < 4.10.14; >= 5.0.0, < 5.2.5; fixed in 5.2.5, 4.10.14

## Suggested inspection (read-only)
- `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on parse-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2m6g-crv8-p3c6 (OSV record GHSA-2m6g-crv8-p3c6 lists affected ranges: npm parse-server >=0 =5.0.0 <5.2.5 (fixed))
- Verified: https://github.com/advisories/GHSA-2m6g-crv8-p3c6 (GitHub-reviewed advisory GHSA-2m6g-crv8-p3c6 lists affected ranges: npm parse-server >=0 =5.0.0 <5.2.5)

Commands are suggestions: review each one before running it.

Loading voting…