Binary vulnerable to Slice Memory Allocation with Excessive Size Value
CVE-2022-36078GHSA-4p6f-m4f9-ch88
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/gagliardetto/binary 0.7.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/gagliardetto/binary
- Affected
- < 0.7.1
- Fixed in
- 0.7.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4p6f-m4f9-ch88 lists affected ranges: Go github.com/gagliardetto/binary >=0 <0.7.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-36078: 1.21% estimated exploitation activity in the next 30 days; percentile 68.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact What kind of vulnerability is it? Who is impacted? The vulnerability is a memory allocation vulnerability that can be exploited to allocate slices in memory with (arbitrary) excessive size value, which can either exhaust available memory or crash the whole program. When using github.com/gagliardetto/binary to parse unchecked (or wrong type of) data from untrusted sources of input (e.g. the blockchain) into slices, it's possible to allocate memory with excessive size. When dec.Decode(&val) method is used to parse data into a structure that is or contains slices of values, the length of the slice was previously read directly from the data itself without any checks on the size of it, and then a slice was allocated. This could lead to an overflow and an allocation of memory with excessive size value. Example: Patches Has the problem been patched? What versions should users upgrade to? The vulnerability has been patched in github.com/gagliardetto/binary v0.7.1 Users should upgrade…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4p6f-m4f9-ch88
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-36078 Advisory: Binary vulnerable to Slice Memory Allocation with Excessive Size Value IDs: CVE-2022-36078, GHSA-4p6f-m4f9-ch88 Record: https://patchnext.com/advisories/cve-2022-36078 (revision 1, source checked 26 Oct 2026, 14:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/gagliardetto/binary 0.7.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/gagliardetto/binary: affected < 0.7.1; fixed in 0.7.1 ## Suggested inspection (read-only) - Go github.com/gagliardetto/binary: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/gagliardetto/binary. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4p6f-m4f9-ch88 (GitHub-reviewed advisory GHSA-4p6f-m4f9-ch88 lists affected ranges: Go github.com/gagliardetto/binary >=0 <0.7.1) Commands are suggestions: review each one before running it.
Loading voting…