Skip to content

← Actionable
High, CVSS 7.5amended

NodeBB account takeover via SSO plugins

CVE-2022-36076GHSA-xmgg-fx9p-prq6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nodebb 1.17.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm nodebb

    Affected
    <= 1.17.1
    Fixed in
    1.17.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-36076: 0.58% estimated exploitation activity in the next 30 days; percentile 47.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

This is a historical security advisory, pertaining to a vulnerability that was reported, patched, and published in 2021. It is listed here for completeness and for CVE tracking purposes. Impact Due to an unnecessarily strict conditional in the code handling the first step of the SSO process, the pre-existing logic that added (and later checked) a nonce was inadvertently rendered opt-in instead of opt-out. This re-exposed a vulnerability in that a specially crafted MITM attack could theoretically take over another user account during the single sign-on process. Patches The issue has been fully patched as of v1.17.2. The patch commit can be found at https://github.com/NodeBB/NodeBB/commit/a2400f6baff44cb2996487bcd0cc6e2acc74b3d4 Workarounds Site maintainers can cherry-pick https://github.com/NodeBB/NodeBB/commit/a2400f6baff44cb2996487bcd0cc6e2acc74b3d4 into their codebase to patch the exploit. References https://blogs.opera.com/security/2022/03/bug-bounty-adventures-a-nodebb-0-day/ For…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-xmgg-fx9p-prq6

  2. Revision 1 · created ·

    Published from osv record GHSA-xmgg-fx9p-prq6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-36076

Advisory: NodeBB account takeover via SSO plugins
IDs: CVE-2022-36076, GHSA-xmgg-fx9p-prq6
Record: https://patchnext.com/advisories/cve-2022-36076 (revision 2, source checked 26 Oct 2026, 12:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nodebb 1.17.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm nodebb: affected <= 1.17.1; fixed in 1.17.2

## Suggested inspection (read-only)
- `npm ls nodebb --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nodebb.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xmgg-fx9p-prq6 (OSV record GHSA-xmgg-fx9p-prq6 lists affected ranges: npm nodebb >=0 <1.17.2 (fixed))
- Verified: https://github.com/advisories/GHSA-xmgg-fx9p-prq6 (GitHub-reviewed advisory GHSA-xmgg-fx9p-prq6 lists affected ranges: npm nodebb >=0 <=1.17.1)

Commands are suggestions: review each one before running it.

Loading voting…