Poetry vulnerable to Untrusted Search Path leading to Local Code Execution on Windows
CVE-2022-36070GHSA-j4j9-7hg9-97g6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (poetry 1.1.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI poetry
- Affected
- < 1.1.9
- Fixed in
- 1.1.9
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-j4j9-7hg9-97g6 lists affected ranges: PyPI poetry >=0 <1.1.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j4j9-7hg9-97g6 lists affected ranges: PyPI poetry >=0 <1.1.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-36070: 0.36% estimated exploitation activity in the next 30 days; percentile 30.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Observation To handle dependencies that come from a Git repository, Poetry executes various commands, e.g. git config. These commands are being executed using the executable’s name and not its absolute path. This can lead to the execution of untrusted code due to the way Windows resolves executable names to paths. Unlike Linux-based operating systems, Windows searches for the executable in the current directory first and looks in the paths that are defined in the PATH environment variable afterward. If the current directory contains unknown and thus potentially malicious files, the directory could contain an executable named git.exe which would be executed by Poetry. Poetry calls executables by name when handling dependencies from Git. Note that there might be even more places where Poetry calls executables by name. Impact This vulnerability can lead to Arbitrary Code Execution, which would lead to the takeover of the system. If a developer is exploited, the attacker could steal…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-j4j9-7hg9-97g6
- Revision 1 · created ·
Published from osv record GHSA-j4j9-7hg9-97g6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-36070 Advisory: Poetry vulnerable to Untrusted Search Path leading to Local Code Execution on Windows IDs: CVE-2022-36070, GHSA-j4j9-7hg9-97g6 Record: https://patchnext.com/advisories/cve-2022-36070 (revision 2, source checked 26 Oct 2026, 13:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: poetry 1.1.9. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI poetry: affected < 1.1.9; fixed in 1.1.9 ## Suggested inspection (read-only) - `python -m pip show poetry`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on poetry. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-j4j9-7hg9-97g6 (OSV record GHSA-j4j9-7hg9-97g6 lists affected ranges: PyPI poetry >=0 <1.1.9 (fixed)) - Verified: https://github.com/advisories/GHSA-j4j9-7hg9-97g6 (GitHub-reviewed advisory GHSA-j4j9-7hg9-97g6 lists affected ranges: PyPI poetry >=0 <1.1.9) Commands are suggestions: review each one before running it.
Loading voting…