Skip to content

← Actionable
High, CVSS 7.3amended

Poetry Argument Injection can lead to Local Code Execution

CVE-2022-36069GHSA-9xgj-fcgf-x6mw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (poetry 1.1.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI poetry

    Affected
    < 1.1.9
    Fixed in
    1.1.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2022-36069: 1.32% estimated exploitation activity in the next 30 days; percentile 70.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Observation When handling dependencies that come from a Git repository instead of a registry, Poetry uses various commands, such as git clone. These commands are being constructed using user input (e.g. the repository URL). When building the commands, Poetry correctly avoids Command Injection vulnerabilities by passing an array of arguments instead of a command string. However, there is the possibility that a user input starts with a dash (-) and is therefore treated as an optional argument instead of a positional one. This can lead to Code Execution because some of the commands have options that can be leveraged to run arbitrary executables. To clone a repository, Poetry builds a git clone command, but fails to validate or sanitize the repository location properly: poetry/core/vcs/git.py: Since this value comes from the pyproject.toml file, it can contain any character, including a leading dash. Impact This vulnerability can lead to Arbitrary Code Execution, which would lead to the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-9xgj-fcgf-x6mw

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-9xgj-fcgf-x6mw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-36069

Advisory: Poetry Argument Injection can lead to Local Code Execution
IDs: CVE-2022-36069, GHSA-9xgj-fcgf-x6mw
Record: https://patchnext.com/advisories/cve-2022-36069 (revision 3, source checked 26 Oct 2026, 13:22 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: poetry 1.1.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI poetry: affected < 1.1.9; fixed in 1.1.9

## Suggested inspection (read-only)
- `python -m pip show poetry`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on poetry.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9xgj-fcgf-x6mw (OSV record GHSA-9xgj-fcgf-x6mw lists affected ranges: PyPI poetry >=0 <1.1.9 (fixed))
- Verified: https://github.com/advisories/GHSA-9xgj-fcgf-x6mw (GitHub-reviewed advisory GHSA-9xgj-fcgf-x6mw lists affected ranges: PyPI poetry >=0 <1.1.9)

Commands are suggestions: review each one before running it.

Loading voting…