Skip to content

← Actionable
Critical, CVSS 10.0amended

vm2 vulnerable to Sandbox Escape resulting in Remote Code Execution on host

CVE-2022-36067GHSA-mrgp-mrhc-5jrq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vm2 3.9.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm vm2

    Affected
    < 3.9.11
    Fixed in
    3.9.11

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2022-36067: 47.87% estimated exploitation activity in the next 30 days; percentile 98.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A threat actor can bypass the sandbox protections to gain remote code execution rights on the host running the sandbox. Patches This vulnerability was patched in the release of version 3.9.11 of vm2 Workarounds None. References Github Issue - https://github.com/patriksimek/vm2/issues/467 The file that was patched - https://github.com/patriksimek/vm2/blob/master/lib/setup-sandbox.js#L71 The commit with the patch - https://github.com/patriksimek/vm2/commit/d9a7f3cc995d3d861e1380eafb886cb3c5e2b873#diff-b1a515a627d820118e76d0e323fe2f0589ed50a1eacb490f6c3278fe3698f164 For more information If you have any questions or comments about this advisory: Open an issue in VM2

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mrgp-mrhc-5jrq

  2. Revision 1 · created ·

    Published from osv record GHSA-mrgp-mrhc-5jrq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-36067

Advisory: vm2 vulnerable to Sandbox Escape resulting in Remote Code Execution on host
IDs: CVE-2022-36067, GHSA-mrgp-mrhc-5jrq
Record: https://patchnext.com/advisories/cve-2022-36067 (revision 2, source checked 26 Oct 2026, 12:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vm2 3.9.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm vm2: affected < 3.9.11; fixed in 3.9.11

## Suggested inspection (read-only)
- `npm ls vm2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vm2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mrgp-mrhc-5jrq (OSV record GHSA-mrgp-mrhc-5jrq lists affected ranges: npm vm2 >=0 <3.9.11 (fixed))
- Verified: https://github.com/advisories/GHSA-mrgp-mrhc-5jrq (GitHub-reviewed advisory GHSA-mrgp-mrhc-5jrq lists affected ranges: npm vm2 >=0 <3.9.11)

Commands are suggestions: review each one before running it.

Loading voting…