Cryptographically weak PRNG in utils.generateUUID
CVE-2022-36045GHSA-p4cc-w597-6cpm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nodebb 2.0.1, 1.19.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm nodebb
- Affected
- < 1.19.8>= 2.0.0, <= 2.0.0
- Fixed in
- 2.0.1, 1.19.8
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p4cc-w597-6cpm lists affected ranges: npm nodebb >=0 =2.0.0 <2.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p4cc-w597-6cpm lists affected ranges: npm nodebb >=0 =2.0.0 <=2.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-36045: 1.35% estimated exploitation activity in the next 30 days; percentile 71.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In Brief utils.generateUUID, a helper function available in essentially all versions of NodeBB (as far back as v1.0.1 and potentially earlier) used a cryptographically insecure Pseudo-random number generator (Math.random()), which meant that a specially crafted script combined with multiple invocations of the password reset functionality could enable an attacker to correctly calculate the reset code for an account they do not have access to. Impact This vulnerability impacts all installations of NodeBB. The vulnerability allows for an attacker to take over any account without the involvement of the victim, and as such, the remediation should be applied immediately (either via NodeBB upgrade or cherry-pick of the specific changeset. Patches have been provided for both active branches of NodeBB (v2.x and v1.19.x)—please see below. If you are already on v2.0.0 or v1.19.7, you can upgrade with no ill effects. The new version contains only the patch for this vulnerability. The impact of…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-p4cc-w597-6cpm
- Revision 1 · created ·
Published from osv record GHSA-p4cc-w597-6cpm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-36045 Advisory: Cryptographically weak PRNG in `utils.generateUUID` IDs: CVE-2022-36045, GHSA-p4cc-w597-6cpm Record: https://patchnext.com/advisories/cve-2022-36045 (revision 2, source checked 26 Oct 2026, 12:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nodebb 2.0.1, 1.19.8. A vendor fix does not mean a deployment is fixed. ## Affected components - npm nodebb: affected < 1.19.8; >= 2.0.0, <= 2.0.0; fixed in 2.0.1, 1.19.8 ## Suggested inspection (read-only) - `npm ls nodebb --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nodebb. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-p4cc-w597-6cpm (OSV record GHSA-p4cc-w597-6cpm lists affected ranges: npm nodebb >=0 =2.0.0 <2.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-p4cc-w597-6cpm (GitHub-reviewed advisory GHSA-p4cc-w597-6cpm lists affected ranges: npm nodebb >=0 =2.0.0 <=2.0.0) Commands are suggestions: review each one before running it.
Loading voting…