Skip to content

← Actionable
Low, CVSS 3.6amended

Improper Control of Generation of Code ('Code Injection') in mdx-mermaid

CVE-2022-36036GHSA-rvgm-35jw-q628

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mdx-mermaid 2.0.0-rc2, 1.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm mdx-mermaid

    Affected
    < 1.3.0>= 2.0.0-rc1, <= 2.0.0-rc1
    Fixed in
    1.3.0, 2.0.0-rc2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.6 · CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2022-36036: 0.40% estimated exploitation activity in the next 30 days; percentile 34.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Arbitary javascript injection Modify any mermaid code blocks with the following code and the code inside will execute when the component is loaded by MDXjs The block below shows a valid mermaid code block mermaid graph TD; A--B; A--C; B--D; C--D; The same block but with the exploit added mermaid + (function () { alert('vulnerable') return '' }()) + graph TD; A--B; A--C; B--D; C--D; Patches 1.3.0 and 2.0.0-rc2 Workarounds None known

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-rvgm-35jw-q628

  2. Revision 1 · created ·

    Published from osv record GHSA-rvgm-35jw-q628

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-36036

Advisory: Improper Control of Generation of Code ('Code Injection') in mdx-mermaid
IDs: CVE-2022-36036, GHSA-rvgm-35jw-q628
Record: https://patchnext.com/advisories/cve-2022-36036 (revision 2, source checked 26 Oct 2026, 12:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mdx-mermaid 2.0.0-rc2, 1.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm mdx-mermaid: affected < 1.3.0; >= 2.0.0-rc1, <= 2.0.0-rc1; fixed in 1.3.0, 2.0.0-rc2

## Suggested inspection (read-only)
- `npm ls mdx-mermaid --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mdx-mermaid.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rvgm-35jw-q628 (OSV record GHSA-rvgm-35jw-q628 lists affected ranges: npm mdx-mermaid >=0 =2.0.0-rc1 <2.0.0-rc2 (fixed))
- Verified: https://github.com/advisories/GHSA-rvgm-35jw-q628 (GitHub-reviewed advisory GHSA-rvgm-35jw-q628 lists affected ranges: npm mdx-mermaid >=0 =2.0.0-rc1 <=2.0.0-rc1)

Commands are suggestions: review each one before running it.

Loading voting…