Skip to content

← Actionable
Critical, CVSS 9.1

Besu VM vulnerable to gas allocation error in CALL operations

CVE-2022-36025GHSA-4456-w38r-m53x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.hyperledger.besu:evm 22.7.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
EPSS
  • CVE-2022-36025: 1.05% estimated exploitation activity in the next 30 days; percentile 64.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An error in 32 bit signed and unsigned types in the calculation of available gas in the CALL operations (including DELEGATECALL) results in incorrect gas being passed into called contracts and incorrect gas being returned after call execution. Where the amount of gas makes a difference in the success or failure, or if the gas is a negative 64 bit value, the execution will result in a different state root than expected, resulting in a consensus failure in networks with multiple EVM implementations. In networks with a single EVM implementation this can be used to execute with significantly more gas than then transaction requested, possibly exceeding gas limitations. Patches Version 22.7.1 contains a fix, ensuring that excess gas will not be allocated to inner transaction calls and correcting the excess gas errors. Workarounds Reverting to version 22.1.3 or earlier will prevent incorrect execution. However many ethereum mainnet networks require changes in more recent versions of…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4456-w38r-m53x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-36025

Advisory: Besu VM vulnerable to gas allocation error in CALL operations
IDs: CVE-2022-36025, GHSA-4456-w38r-m53x
Record: https://patchnext.com/advisories/cve-2022-36025 (revision 1, source checked 26 Oct 2026, 16:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.hyperledger.besu:evm 22.7.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.hyperledger.besu:evm: affected >= 22.4.0-RC1, < 22.7.1; fixed in 22.7.1

## Suggested inspection (read-only)
- Maven org.hyperledger.besu:evm: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.hyperledger.besu:evm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4456-w38r-m53x (GitHub-reviewed advisory GHSA-4456-w38r-m53x lists affected ranges: Maven org.hyperledger.besu:evm >=22.4.0-RC1 <22.7.1)

Commands are suggestions: review each one before running it.

Loading voting…