@actions/core has Delimiter Injection Vulnerability in exportVariable
CVE-2022-35954GHSA-7r3h-m5j6-3q42
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@actions/core 1.9.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @actions/core
- Affected
- <= 1.9.0
- Fixed in
- 1.9.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7r3h-m5j6-3q42 lists affected ranges: npm @actions/core >=0 <1.9.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7r3h-m5j6-3q42 lists affected ranges: npm @actions/core >=0 <=1.9.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.0 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:N
- EPSS
- CVE-2022-35954: 0.70% estimated exploitation activity in the next 30 days; percentile 53.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The core.exportVariable function uses a well known delimiter that attackers can use to break out of that specific variable and assign values to other arbitrary variables. Workflows that write untrusted values to the GITHUBENV file may cause the path or other environment variables to be modified without the intention of the workflow or action author. Patches Users should upgrade to @actions/core v1.9.1. Workarounds If you are unable to upgrade the @actions/core package, you can modify your action to ensure that any user input does not contain the delimiter GitHubActionsFileCommandDelimeter before calling core.exportVariable. References More information about setting-an-environment-variable in workflows If you have any questions or comments about this advisory: Open an issue in actions/toolkit
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7r3h-m5j6-3q42
- Revision 1 · created ·
Published from osv record GHSA-7r3h-m5j6-3q42
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-35954 Advisory: @actions/core has Delimiter Injection Vulnerability in exportVariable IDs: CVE-2022-35954, GHSA-7r3h-m5j6-3q42 Record: https://patchnext.com/advisories/cve-2022-35954 (revision 2, source checked 26 Oct 2026, 12:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @actions/core 1.9.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @actions/core: affected <= 1.9.0; fixed in 1.9.1 ## Suggested inspection (read-only) - `npm ls @actions/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @actions/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7r3h-m5j6-3q42 (OSV record GHSA-7r3h-m5j6-3q42 lists affected ranges: npm @actions/core >=0 <1.9.1 (fixed)) - Verified: https://github.com/advisories/GHSA-7r3h-m5j6-3q42 (GitHub-reviewed advisory GHSA-7r3h-m5j6-3q42 lists affected ranges: npm @actions/core >=0 <=1.9.0) Commands are suggestions: review each one before running it.
Loading voting…