Skip to content

← Actionable
Medium, CVSS 5.9amended

TensorFlow vulnerable to CHECK failures in UnbatchGradOp

CVE-2022-35952GHSA-h5vq-gw2c-pq47

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tensorflow 2.9.1, 2.8.1, 2.7.2; tensorflow-gpu 2.9.1, 2.8.1, 2.7.2; tensorflow-cpu 2.9.1, 2.8.1, 2.7.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI tensorflow

    Affected
    < 2.7.2>= 2.8.0, < 2.8.1>= 2.9.0, < 2.9.1
    Fixed in
    2.8.1, 2.7.2, 2.9.1
  • PyPI tensorflow-gpu

    Affected
    < 2.7.2>= 2.8.0, < 2.8.1>= 2.9.0, < 2.9.1
    Fixed in
    2.8.1, 2.7.2, 2.9.1
  • PyPI tensorflow-cpu

    Affected
    < 2.7.2>= 2.8.0, < 2.8.1>= 2.9.0, < 2.9.1
    Fixed in
    2.8.1, 2.7.2, 2.9.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-35952: 0.72% estimated exploitation activity in the next 30 days; percentile 53.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The UnbatchGradOp function takes an argument id that is assumed to be a scalar. A nonscalar id can trigger a CHECK failure and crash the program. It also requires its argument batchindex to contain three times the number of elements as indicated in its batchindex.dimsize(0). An incorrect batchindex can trigger a CHECK failure and crash the program. Patches We have patched the issue in GitHub commit 5f945fc6409a3c1e90d6970c9292f805f6e6ddf2. The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range. For more information Please consult our security guide for more information regarding the security model and how to contact us with issues and questions. Attribution This vulnerability has been reported by Kang Hong Jin from Singapore Management University and 刘力源 from the Information System & Security and Countermeasures Experiments Center,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-h5vq-gw2c-pq47

  2. Revision 1 · created ·

    Published from osv record GHSA-h5vq-gw2c-pq47

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-35952

Advisory: TensorFlow vulnerable to `CHECK` failures in `UnbatchGradOp`
IDs: CVE-2022-35952, GHSA-h5vq-gw2c-pq47
Record: https://patchnext.com/advisories/cve-2022-35952 (revision 2, source checked 26 Oct 2026, 13:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tensorflow 2.9.1, 2.8.1, 2.7.2; tensorflow-gpu 2.9.1, 2.8.1, 2.7.2; tensorflow-cpu 2.9.1, 2.8.1, 2.7.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI tensorflow: affected < 2.7.2; >= 2.8.0, < 2.8.1; >= 2.9.0, < 2.9.1; fixed in 2.8.1, 2.7.2, 2.9.1
- PyPI tensorflow-gpu: affected < 2.7.2; >= 2.8.0, < 2.8.1; >= 2.9.0, < 2.9.1; fixed in 2.8.1, 2.7.2, 2.9.1
- PyPI tensorflow-cpu: affected < 2.7.2; >= 2.8.0, < 2.8.1; >= 2.9.0, < 2.9.1; fixed in 2.8.1, 2.7.2, 2.9.1

## Suggested inspection (read-only)
- `python -m pip show tensorflow`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show tensorflow-gpu`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show tensorflow-cpu`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tensorflow, tensorflow-gpu, tensorflow-cpu.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-h5vq-gw2c-pq47 (OSV record GHSA-h5vq-gw2c-pq47 lists affected ranges: PyPI tensorflow >=0 =2.8.0 =2.9.0 =0 =2.8.0 =2.9.0 =0 =2.8.0 =2.9.0 <2.9.1 (fixed))
- Verified: https://github.com/advisories/GHSA-h5vq-gw2c-pq47 (GitHub-reviewed advisory GHSA-h5vq-gw2c-pq47 lists affected ranges: PyPI tensorflow >=0 =2.8.0 =2.9.0 =0 =2.8.0 =2.9.0 =0 =2.8.0 =2.9.0 <2.9.1)

Commands are suggestions: review each one before running it.

Loading voting…