undici.request vulnerable to SSRF using absolute URL on pathname
CVE-2022-35949GHSA-8qr4-xgw6-wmr3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (undici 5.8.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm undici
- Affected
- <= 5.8.1
- Fixed in
- 5.8.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8qr4-xgw6-wmr3 lists affected ranges: npm undici >=0 <5.8.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8qr4-xgw6-wmr3 lists affected ranges: npm undici >=0 <=5.8.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2022-35949: 1.93% estimated exploitation activity in the next 30 days; percentile 79.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact undici is vulnerable to SSRF (Server-side Request Forgery) when an application takes in user input into the path/pathname option of undici.request. If a user specifies a URL such as http://127.0.0.1 or //127.0.0.1 Instead of processing the request as http://example.org//127.0.0.1 (or http://example.org/http://127.0.0.1 when http://127.0.0.1 is used), it actually processes the request as http://127.0.0.1/ and sends it to http://127.0.0.1. If a developer passes in user input into path parameter of undici.request, it can result in an SSRF as they will assume that the hostname cannot change, when in actual fact it can change because the specified path parameter is combined with the base URL. Patches This issue was fixed in undici@5.8.1. Workarounds The best workaround is to validate user input before passing it to the undici.request call. For more information If you have any questions or comments about this advisory: - Open an issue in undici repository - To make a report, follow…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-8qr4-xgw6-wmr3
- Revision 1 · created ·
Published from osv record GHSA-8qr4-xgw6-wmr3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-35949 Advisory: `undici.request` vulnerable to SSRF using absolute URL on `pathname` IDs: CVE-2022-35949, GHSA-8qr4-xgw6-wmr3 Record: https://patchnext.com/advisories/cve-2022-35949 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: undici 5.8.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm undici: affected <= 5.8.1; fixed in 5.8.2 ## Suggested inspection (read-only) - `npm ls undici --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on undici. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8qr4-xgw6-wmr3 (OSV record GHSA-8qr4-xgw6-wmr3 lists affected ranges: npm undici >=0 <5.8.2 (fixed)) - Verified: https://github.com/advisories/GHSA-8qr4-xgw6-wmr3 (GitHub-reviewed advisory GHSA-8qr4-xgw6-wmr3 lists affected ranges: npm undici >=0 <=5.8.1) Commands are suggestions: review each one before running it.
Loading voting…