Skip to content

← Actionable
Medium, CVSS 5.9

CodeIgniter Shield Vulnerable to SameSite Attackers Bypassing the CSRF Protection

CVE-2022-35943GHSA-5hm8-vh6r-2cjq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (codeigniter4/shield 1.0.0-beta.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:L
EPSS
  • CVE-2022-35943: 0.61% estimated exploitation activity in the next 30 days; percentile 49.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact This vulnerability may allow SameSite Attackers to bypass the CodeIgniter4 CSRF protection mechanism with CodeIgniter Shield. For this attack to succeed, the attacker must have direct (or indirect, e.g., XSS) control over a subdomain site (e.g., https://a.example.com/) of the target site (e.g., http://example.com/). This vulnerability exists whether Config\Security::$csrfProtection is 'cookie' or 'session'. It is also exploitable whether Config\Security::$regenerate is true or false. Patches Upgrade to CodeIgniter v4.2.3 or later and Shield v1.0.0-beta.2 or later. Workarounds Do all of the following: - set Config\Security::$csrfProtection to 'session' - remove old session data right after login (immediately after ID and password match) - regenerate CSRF token right after login (immediately after ID and password match) References - CodeIgniter4 CSRF Protection - SameSite Attacks - SameSite Cookies - The great SameSite confusion For more information If you have any questions or…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5hm8-vh6r-2cjq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-35943

Advisory: CodeIgniter Shield Vulnerable to SameSite Attackers Bypassing the CSRF Protection
IDs: CVE-2022-35943, GHSA-5hm8-vh6r-2cjq
Record: https://patchnext.com/advisories/cve-2022-35943 (revision 1, source checked 26 Oct 2026, 14:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: codeigniter4/shield 1.0.0-beta.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist codeigniter4/shield: affected >= 1.0.0-beta, <= 1.0.0-beta; fixed in 1.0.0-beta.2

## Suggested inspection (read-only)
- Packagist codeigniter4/shield: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on codeigniter4/shield.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5hm8-vh6r-2cjq (GitHub-reviewed advisory GHSA-5hm8-vh6r-2cjq lists affected ranges: Packagist codeigniter4/shield >=1.0.0-beta <=1.0.0-beta)

Commands are suggestions: review each one before running it.

Loading voting…