Skip to content

← Actionable
Critical, CVSS 9.3amended

loopback-connector-postgresql Vulnerable to Improper Sanitization of contains Filter

CVE-2022-35942GHSA-j259-6c58-9m58

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (loopback-connector-postgresql 5.5.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.3 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2022-35942: 0.66% estimated exploitation activity in the next 30 days; percentile 51.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Improper input validation on the contains LoopBack filter may allow for arbitrary SQL injection. Impact When the extended filter property contains is permitted to be interpreted by the Postgres connector, it is possible to inject arbitrary SQL which may affect the confidentiality and integrity of data stored on the connected database. This affects users who does any of the following: - Connect to the database via the DataSource with allowExtendedProperties: true setting OR - Uses the connector's CRUD methods directly OR - Uses the connector's other methods to interpret the LoopBack filter. Patches Patch release loopback-connector-postgresql@5.5.1 has been published of which resolves this issue. Workarounds Users who are unable to upgrade should do the following if applicable: - Remove allowExtendedProperties: true DataSource setting - Add allowExtendedProperties: false DataSource setting - When passing directly to the connector functions, manually sanitize the user input for the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-j259-6c58-9m58

  2. Revision 1 · created ·

    Published from osv record GHSA-j259-6c58-9m58

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-35942

Advisory: loopback-connector-postgresql Vulnerable to Improper Sanitization of `contains` Filter
IDs: CVE-2022-35942, GHSA-j259-6c58-9m58
Record: https://patchnext.com/advisories/cve-2022-35942 (revision 2, source checked 26 Oct 2026, 12:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: loopback-connector-postgresql 5.5.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm loopback-connector-postgresql: affected < 5.5.1; fixed in 5.5.1

## Suggested inspection (read-only)
- `npm ls loopback-connector-postgresql --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on loopback-connector-postgresql.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-j259-6c58-9m58 (OSV record GHSA-j259-6c58-9m58 lists affected ranges: npm loopback-connector-postgresql >=0 <5.5.1 (fixed))
- Verified: https://github.com/advisories/GHSA-j259-6c58-9m58 (GitHub-reviewed advisory GHSA-j259-6c58-9m58 lists affected ranges: npm loopback-connector-postgresql >=0 <5.5.1)

Commands are suggestions: review each one before running it.

Loading voting…