Skip to content

← Actionable
High, CVSS 8.2

Ethermint vulnerable to DoS through unintended Contract Selfdestruct

CVE-2022-35936GHSA-f92v-grc2-w2fg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/Kava-Labs/kava 0.18.0; github.com/evmos/evmos 7.0.0; github.com/evmos/ethermint 0.18.0; github.com/crypto-org-chain/cronos 0.7.1-rc2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H
EPSS
  • CVE-2022-35936: 1.47% estimated exploitation activity in the next 30 days; percentile 73.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Vulnerability Report Impact Smart contract applications that make use of the selfdestruct functionality and their end-users. Classification The vulnerability has been classified as high with a CVSS score of 8.2. It has the potential to create a denial-of-service to all contracts that can invoke the selfdestruct function to destroy a smart contract. Users Impacted Due to the successfully coordinated security vulnerability disclosure, no smart contracts were impacted through the use of this vulnerability. Smart contract states and storage values are not affected by this vulnerability. User funds and balances are safe. Disclosure In Ethermint running versions before v0.17.2, the contract selfdestruct invocation permanently removes the corresponding bytecode from the internal database storage. However, due to a bug in the DeleteAccount function, all contracts that used the identical bytecode (i.e shared the same CodeHash) will also stop working once one contract invokes selfdestruct,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-f92v-grc2-w2fg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-35936

Advisory: Ethermint vulnerable to DoS through unintended Contract Selfdestruct
IDs: CVE-2022-35936, GHSA-f92v-grc2-w2fg
Record: https://patchnext.com/advisories/cve-2022-35936 (revision 1, source checked 26 Oct 2026, 14:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/Kava-Labs/kava 0.18.0; github.com/evmos/evmos 7.0.0; github.com/evmos/ethermint 0.18.0; github.com/crypto-org-chain/cronos 0.7.1-rc2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/Kava-Labs/kava: affected <= 0.17.5; fixed in 0.18.0
- Go github.com/evmos/evmos: affected <= 6.0.3; fixed in 7.0.0
- Go github.com/evmos/ethermint: affected <= 0.17.2; fixed in 0.18.0
- Go github.com/crypto-org-chain/cronos: affected <= 0.7.0; fixed in 0.7.1-rc2

## Suggested inspection (read-only)
- Go github.com/Kava-Labs/kava: check the installed version with your package manager.
- Go github.com/evmos/evmos: check the installed version with your package manager.
- Go github.com/evmos/ethermint: check the installed version with your package manager.
- Go github.com/crypto-org-chain/cronos: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/Kava-Labs/kava, github.com/evmos/evmos, github.com/evmos/ethermint, github.com/crypto-org-chain/cronos.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-f92v-grc2-w2fg (GitHub-reviewed advisory GHSA-f92v-grc2-w2fg lists affected ranges: Go github.com/evmos/ethermint >=0 =0 =0 =0 <=0.17.5)

Commands are suggestions: review each one before running it.

Loading voting…