NextAuth.js before 4.10.3 and 3.29.10 sending verification requests (magic link) to unwanted emails
CVE-2022-35924GHSA-xv97-c62v-4587
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (next-auth 4.10.3, 3.29.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm next-auth
- Affected
- >= 4.0.0, < 4.10.3< 3.29.10
- Fixed in
- 4.10.3, 3.29.10
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xv97-c62v-4587 lists affected ranges: npm next-auth >=4.0.0 =0 <3.29.10 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xv97-c62v-4587 lists affected ranges: npm next-auth >=4.0.0 =0 <3.29.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2022-35924: 1.47% estimated exploitation activity in the next 30 days; percentile 73.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact next-auth users who are using the EmailProvider either in versions before 4.10.3 or 3.29.10 are affected. If an attacker could forge a request that sent a comma-separated list of emails (eg.: attacker@attacker.com,victim@victim.com) to the sign-in endpoint, NextAuth.js would send emails to both the attacker and the victim's e-mail addresses. The attacker could then login as a newly created user with the email being attacker@attacker.com,victim@victim.com. This means that basic authorization like email.endsWith("@victim.com") in the signIn callback would fail to communicate a threat to the developer and would let the attacker bypass authorization, even with an @attacker.com address. Patches We patched this vulnerability in v4.10.3 and v3.29.10 by normalizing the email value that is sent to the sign-in endpoint before accessing it anywhere else. We also added a normalizeIdentifier callback on the EmailProvider configuration, where you can further tweak your requirements for what…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-xv97-c62v-4587
- Revision 1 · created ·
Published from osv record GHSA-xv97-c62v-4587
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-35924 Advisory: NextAuth.js before 4.10.3 and 3.29.10 sending verification requests (magic link) to unwanted emails IDs: CVE-2022-35924, GHSA-xv97-c62v-4587 Record: https://patchnext.com/advisories/cve-2022-35924 (revision 2, source checked 26 Oct 2026, 12:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: next-auth 4.10.3, 3.29.10. A vendor fix does not mean a deployment is fixed. ## Affected components - npm next-auth: affected >= 4.0.0, < 4.10.3; < 3.29.10; fixed in 4.10.3, 3.29.10 ## Suggested inspection (read-only) - `npm ls next-auth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on next-auth. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xv97-c62v-4587 (OSV record GHSA-xv97-c62v-4587 lists affected ranges: npm next-auth >=4.0.0 =0 <3.29.10 (fixed)) - Verified: https://github.com/advisories/GHSA-xv97-c62v-4587 (GitHub-reviewed advisory GHSA-xv97-c62v-4587 lists affected ranges: npm next-auth >=4.0.0 =0 <3.29.10) Commands are suggestions: review each one before running it.
Loading voting…