v8n vulnerable to Inefficient Regular Expression Complexity
CVE-2022-35923GHSA-xrx9-gj26-5wx9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (v8n 1.5.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm v8n
- Affected
- < 1.5.1
- Fixed in
- 1.5.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xrx9-gj26-5wx9 lists affected ranges: npm v8n >=0 <1.5.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xrx9-gj26-5wx9 lists affected ranges: npm v8n >=0 <1.5.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2022-35923: 1.76% estimated exploitation activity in the next 30 days; percentile 78.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Inefficient regular expression complexity of lowercase() and uppercase() regex could lead to a denial of service attack. With a formed payload 'a' + 'a'.repeat(i) + 'A', only 32 characters payload could take 29443 ms time execution when testing lowercase(). The same issue happens with uppercase(). Patches v1.5.1 References huntr.dev report Regular Expression Denial of Service (ReDoS) and Catastrophic Backtracking For more information If you have any questions or comments about this advisory: Open an issue in v8n issues list Email us at brunodev02221@gmail.com
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-xrx9-gj26-5wx9
- Revision 1 · created ·
Published from osv record GHSA-xrx9-gj26-5wx9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-35923 Advisory: v8n vulnerable to Inefficient Regular Expression Complexity IDs: CVE-2022-35923, GHSA-xrx9-gj26-5wx9 Record: https://patchnext.com/advisories/cve-2022-35923 (revision 2, source checked 26 Oct 2026, 12:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: v8n 1.5.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm v8n: affected < 1.5.1; fixed in 1.5.1 ## Suggested inspection (read-only) - `npm ls v8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on v8n. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xrx9-gj26-5wx9 (OSV record GHSA-xrx9-gj26-5wx9 lists affected ranges: npm v8n >=0 <1.5.1 (fixed)) - Verified: https://github.com/advisories/GHSA-xrx9-gj26-5wx9 (GitHub-reviewed advisory GHSA-xrx9-gj26-5wx9 lists affected ranges: npm v8n >=0 <1.5.1) Commands are suggestions: review each one before running it.
Loading voting…