sanic vulnerable to Path Traversal when using app.static if using encoded %2F URLs
CVE-2022-35920GHSA-8cw9-5hmv-77w6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sanic 22.6.1, 21.12.2, 20.12.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI sanic
- Affected
- >= 22.0.0, < 22.6.1>= 21.0.0, < 21.12.2< 20.12.7
- Fixed in
- 20.12.7, 21.12.2, 22.6.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8cw9-5hmv-77w6 lists affected ranges: PyPI sanic >=22.0.0 =21.0.0 =0 <20.12.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8cw9-5hmv-77w6 lists affected ranges: PyPI sanic >=22.0.0 =21.0.0 =0 <20.12.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L
- EPSS
- CVE-2022-35920: 1.20% estimated exploitation activity in the next 30 days; percentile 68.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Access to lateral directories when using app.static if using encoded %2F URLs. Parent directory traversal is not impacted. Patches - v20.12.7 (LTS) - v21.12.2 (LTS) - v22.6.1 References https://github.com/sanic-org/sanic/issues/2478 https://github.com/sanic-org/sanic/pull/2495 For more information If you have any questions or comments about this advisory: Open an issue in the community forums Ping us on the Discord server
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-8cw9-5hmv-77w6
- Revision 1 · created ·
Published from osv record GHSA-8cw9-5hmv-77w6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-35920 Advisory: sanic vulnerable to Path Traversal when using `app.static` if using encoded `%2F` URLs IDs: CVE-2022-35920, GHSA-8cw9-5hmv-77w6 Record: https://patchnext.com/advisories/cve-2022-35920 (revision 2, source checked 26 Oct 2026, 13:11 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sanic 22.6.1, 21.12.2, 20.12.7. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI sanic: affected >= 22.0.0, < 22.6.1; >= 21.0.0, < 21.12.2; < 20.12.7; fixed in 20.12.7, 21.12.2, 22.6.1 ## Suggested inspection (read-only) - `python -m pip show sanic`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sanic. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8cw9-5hmv-77w6 (OSV record GHSA-8cw9-5hmv-77w6 lists affected ranges: PyPI sanic >=22.0.0 =21.0.0 =0 <20.12.7 (fixed)) - Verified: https://github.com/advisories/GHSA-8cw9-5hmv-77w6 (GitHub-reviewed advisory GHSA-8cw9-5hmv-77w6 lists affected ranges: PyPI sanic >=22.0.0 =21.0.0 =0 <20.12.7) Commands are suggestions: review each one before running it.
Loading voting…