Skip to content

← Actionable
Medium, CVSS 6.5amended

Streamlit directory traversal vulnerability

CVE-2022-35918GHSA-v4hr-4jpx-56gc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (streamlit 1.11.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI streamlit

    Affected
    >= 0.63.0, < 1.11.1
    Fixed in
    1.11.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
EPSS
  • CVE-2022-35918: 1.77% estimated exploitation activity in the next 30 days; percentile 78.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Users hosting Streamlit app(s) that use custom components are vulnerable to a directory traversal attack that could leak data from their web server file-system such as: server logs, world readable files, and potentially other sensitive information. An attacker can craft a malicious URL with file paths and the streamlit server would process that URL and return the contents of that file. Patches On July 27th at 2:20PM PST we rolled out a patch in release 1.11.1. This patch ensures that any file operations are restricted only to the custom component directory and cannot traverse outside of that. We strongly recommend users upgrade to v1.11.1 as soon as possible. We have notified the Streamlit community and popular hosting providers about this issue so they can patch quickly. As a precautionary measure, we are also upgrading all users on Streamlit Cloud wherever possible. We continue to check other occurrences of this vulnerability and monitor potential exploits wherever we can.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-v4hr-4jpx-56gc

  2. Revision 1 · created ·

    Published from osv record GHSA-v4hr-4jpx-56gc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-35918

Advisory: Streamlit directory traversal vulnerability
IDs: CVE-2022-35918, GHSA-v4hr-4jpx-56gc
Record: https://patchnext.com/advisories/cve-2022-35918 (revision 2, source checked 26 Oct 2026, 13:11 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: streamlit 1.11.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI streamlit: affected >= 0.63.0, < 1.11.1; fixed in 1.11.1

## Suggested inspection (read-only)
- `python -m pip show streamlit`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on streamlit.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v4hr-4jpx-56gc (OSV record GHSA-v4hr-4jpx-56gc lists affected ranges: PyPI streamlit >=0.63.0 <1.11.1 (fixed))
- Verified: https://github.com/advisories/GHSA-v4hr-4jpx-56gc (GitHub-reviewed advisory GHSA-v4hr-4jpx-56gc lists affected ranges: PyPI streamlit >=0.63.0 <1.11.1)

Commands are suggestions: review each one before running it.

Loading voting…