Skip to content

← Actionable
Medium, CVSS 5.3amended

OpenZeppelin Contracts's Cross chain utilities for Arbitrum L2 see EOA calls as cross chain calls

CVE-2022-35916GHSA-9j3m-g383-29qr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@openzeppelin/contracts 4.7.2; @openzeppelin/contracts-upgradeable 4.7.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2022-35916: 0.60% estimated exploitation activity in the next 30 days; percentile 48.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Contracts using the cross chain utilies for Arbitrum L2, CrossChainEnabledArbitrumL2 or LibArbitrumL2, will classify direct interactions of externally owned accounts (EOAs) as cross chain calls, even though they are not started on L1. This is assessed as low severity because any action taken by an EOA on the contract could also be taken by the EOA through the bridge if the issue was not present. Patches This issue has been patched in v4.7.2. References https://github.com/OpenZeppelin/openzeppelin-contracts/pull/3578 For more information If you have any questions or comments about this advisory, or need assistance deploying a fix, email us at security@openzeppelin.com.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9j3m-g383-29qr

  2. Revision 1 · created ·

    Published from osv record GHSA-9j3m-g383-29qr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-35916

Advisory: OpenZeppelin Contracts's Cross chain utilities for Arbitrum L2 see EOA calls as cross chain calls
IDs: CVE-2022-35916, GHSA-9j3m-g383-29qr
Record: https://patchnext.com/advisories/cve-2022-35916 (revision 2, source checked 26 Oct 2026, 12:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @openzeppelin/contracts 4.7.2; @openzeppelin/contracts-upgradeable 4.7.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @openzeppelin/contracts: affected >= 4.6.0, < 4.7.2; fixed in 4.7.2
- npm @openzeppelin/contracts-upgradeable: affected >= 4.6.0, < 4.7.2; fixed in 4.7.2

## Suggested inspection (read-only)
- `npm ls @openzeppelin/contracts --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @openzeppelin/contracts-upgradeable --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @openzeppelin/contracts, @openzeppelin/contracts-upgradeable.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9j3m-g383-29qr (OSV record GHSA-9j3m-g383-29qr lists affected ranges: npm @openzeppelin/contracts >=4.6.0 =4.6.0 <4.7.2 (fixed))
- Verified: https://github.com/advisories/GHSA-9j3m-g383-29qr (GitHub-reviewed advisory GHSA-9j3m-g383-29qr lists affected ranges: npm @openzeppelin/contracts >=4.6.0 =4.6.0 <4.7.2)

Commands are suggestions: review each one before running it.

Loading voting…