OpenZeppelin Contracts ERC165Checker unbounded gas consumption
CVE-2022-35915GHSA-7grf-83vw-6f5x
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @openzeppelin/contracts
- Affected
- >= 2.0.0, < 4.7.2
- Fixed in
- 4.7.2
npm @openzeppelin/contracts-upgradeable
- Affected
- >= 3.2.0, < 4.7.2
- Fixed in
- 4.7.2
npm openzeppelin-solidity
- Affected
- >= 2.0.0, <= 4.6.0
- Fixed in
- no fixed version recorded
npm openzeppelin-eth
- Affected
- >= 2.0.0, <= 2.2.0
- Fixed in
- no fixed version recorded
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7grf-83vw-6f5x lists affected ranges: npm @openzeppelin/contracts >=2.0.0 =2.0.0 =3.2.0 =2.0.0 <=2.2.0
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7grf-83vw-6f5x lists affected ranges: npm @openzeppelin/contracts >=2.0.0 =2.0.0 =3.2.0 =2.0.0 <=2.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2022-35915: 0.80% estimated exploitation activity in the next 30 days; percentile 56.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The target contract of an EIP-165 supportsInterface query can cause unbounded gas consumption by returning a lot of data, while it is generally assumed that this operation has a bounded cost. Patches The issue has been fixed in v4.7.2. References https://github.com/OpenZeppelin/openzeppelin-contracts/pull/3587 For more information If you have any questions or comments about this advisory, or need assistance deploying a fix, email us at security@openzeppelin.com.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7grf-83vw-6f5x
- Revision 1 · created ·
Published from osv record GHSA-7grf-83vw-6f5x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-35915 Advisory: OpenZeppelin Contracts ERC165Checker unbounded gas consumption IDs: CVE-2022-35915, GHSA-7grf-83vw-6f5x Record: https://patchnext.com/advisories/cve-2022-35915 (revision 2, source checked 26 Oct 2026, 12:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: @openzeppelin/contracts 4.7.2; @openzeppelin/contracts-upgradeable 4.7.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @openzeppelin/contracts: affected >= 2.0.0, < 4.7.2; fixed in 4.7.2 - npm @openzeppelin/contracts-upgradeable: affected >= 3.2.0, < 4.7.2; fixed in 4.7.2 - npm openzeppelin-solidity: affected >= 2.0.0, <= 4.6.0 - npm openzeppelin-eth: affected >= 2.0.0, <= 2.2.0 ## Suggested inspection (read-only) - `npm ls @openzeppelin/contracts --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @openzeppelin/contracts-upgradeable --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls openzeppelin-solidity --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls openzeppelin-eth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @openzeppelin/contracts, @openzeppelin/contracts-upgradeable, openzeppelin-solidity, openzeppelin-eth. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7grf-83vw-6f5x (OSV record GHSA-7grf-83vw-6f5x lists affected ranges: npm @openzeppelin/contracts >=2.0.0 =2.0.0 =3.2.0 =2.0.0 <=2.2.0) - Verified: https://github.com/advisories/GHSA-7grf-83vw-6f5x (GitHub-reviewed advisory GHSA-7grf-83vw-6f5x lists affected ranges: npm @openzeppelin/contracts >=2.0.0 =2.0.0 =3.2.0 =2.0.0 <=2.2.0) Commands are suggestions: review each one before running it.
Loading voting…