Magento Open Source has Improper Access Control vulnerability
CVE-2022-35692GHSA-gm4m-9rm8-7rxj
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist magento/project-community-edition
- Affected
- <= 2.0.2
- Fixed in
- no fixed version recorded
Packagist magento/community-edition
- Affected
- >= 2.4.3-p1, < 2.4.3-p3>= 2.3.7-p1, < 2.3.7-p4>= 2.3.7, <= 2.3.7>= 2.4.4, <= 2.4.4>= 2.4.3, <= 2.4.3
- Fixed in
- 2.4.3-p3, 2.3.7-p4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gm4m-9rm8-7rxj lists affected ranges: Packagist magento/community-edition >=2.4.3-p1 =2.3.7-p1 =2.3.7 =2.4.4 =2.4.3 =0 <=2.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2022-35692: 0.84% estimated exploitation activity in the next 30 days; percentile 57.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Access Control vulnerability that could result in a Security feature bypass. An attacker could leverage this vulnerability to leak minor information of another user's account details. Exploitation of this issue does not require user interaction.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gm4m-9rm8-7rxj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-35692 Advisory: Magento Open Source has Improper Access Control vulnerability IDs: CVE-2022-35692, GHSA-gm4m-9rm8-7rxj Record: https://patchnext.com/advisories/cve-2022-35692 (revision 1, source checked 26 Oct 2026, 14:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: magento/community-edition 2.4.3-p3, 2.3.7-p4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist magento/project-community-edition: affected <= 2.0.2 - Packagist magento/community-edition: affected >= 2.4.3-p1, < 2.4.3-p3; >= 2.3.7-p1, < 2.3.7-p4; >= 2.3.7, <= 2.3.7; >= 2.4.4, <= 2.4.4; >= 2.4.3, <= 2.4.3; fixed in 2.4.3-p3, 2.3.7-p4 ## Suggested inspection (read-only) - Packagist magento/project-community-edition: check the installed version with your package manager. - Packagist magento/community-edition: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on magento/project-community-edition, magento/community-edition. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gm4m-9rm8-7rxj (GitHub-reviewed advisory GHSA-gm4m-9rm8-7rxj lists affected ranges: Packagist magento/community-edition >=2.4.3-p1 =2.3.7-p1 =2.3.7 =2.4.4 =2.4.3 =0 <=2.0.2) Commands are suggestions: review each one before running it.
Loading voting…