Skip to content

← Actionable
Medium, CVSS 6.1

Moodle Open redirect risk in mobile auto-login feature

CVE-2022-35652GHSA-243v-5pff-qqfj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 4.0.2, 3.11.8, 3.9.15), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist moodle/moodle

    Affected
    >= 4.0, < 4.0.2>= 3.11, < 3.11.8>= 3.9, < 3.9.15
    Fixed in
    4.0.2, 3.11.8, 3.9.15

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2022-35652: 1.09% estimated exploitation activity in the next 30 days; percentile 65.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An open redirect issue was found in Moodle due to improper sanitization of user-supplied data in mobile auto-login feature. A remote attacker can create a link that leads to a trusted website, however, when clicked, it redirects the victims to arbitrary URL/domain. Successful exploitation of this vulnerability may allow a remote attacker to perform a phishing attack and steal potentially sensitive information.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-243v-5pff-qqfj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-35652

Advisory: Moodle Open redirect risk in mobile auto-login feature
IDs: CVE-2022-35652, GHSA-243v-5pff-qqfj
Record: https://patchnext.com/advisories/cve-2022-35652 (revision 1, source checked 26 Oct 2026, 14:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 4.0.2, 3.11.8, 3.9.15. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist moodle/moodle: affected >= 4.0, < 4.0.2; >= 3.11, < 3.11.8; >= 3.9, < 3.9.15; fixed in 4.0.2, 3.11.8, 3.9.15

## Suggested inspection (read-only)
- Packagist moodle/moodle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on moodle/moodle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-243v-5pff-qqfj (GitHub-reviewed advisory GHSA-243v-5pff-qqfj lists affected ranges: Packagist moodle/moodle >=4.0 =3.11 =3.9 <3.9.15)

Commands are suggestions: review each one before running it.

Loading voting…