ForkCMS XSS via publish_on_date parameter
CVE-2022-35587GHSA-65wf-qm95-6mhm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (forkcms/forkcms 5.11.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist forkcms/forkcms
- Affected
- < 5.11.0
- Fixed in
- 5.11.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-65wf-qm95-6mhm lists affected ranges: Packagist forkcms/forkcms >=0 <5.11.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2022-35587: 0.84% estimated exploitation activity in the next 30 days; percentile 57.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A cross-site scripting (XSS) issue in the Fork version 5.9.3 allows remote attackers to inject JavaScript via the publishondate Parameter. This issue was patched in version 5.11.0.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-65wf-qm95-6mhm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-35587 Advisory: ForkCMS XSS via `publish_on_date` parameter IDs: CVE-2022-35587, GHSA-65wf-qm95-6mhm Record: https://patchnext.com/advisories/cve-2022-35587 (revision 1, source checked 26 Oct 2026, 14:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: forkcms/forkcms 5.11.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist forkcms/forkcms: affected < 5.11.0; fixed in 5.11.0 ## Suggested inspection (read-only) - Packagist forkcms/forkcms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on forkcms/forkcms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-65wf-qm95-6mhm (GitHub-reviewed advisory GHSA-65wf-qm95-6mhm lists affected ranges: Packagist forkcms/forkcms >=0 <5.11.0) Commands are suggestions: review each one before running it.
Loading voting…