Skip to content

← Actionable
High, CVSS 7.5

Protobuf Java vulnerable to Uncontrolled Resource Consumption

CVE-2022-3509GHSA-g5ww-5jh7-63cx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.google.protobuf:protobuf-java 3.21.7, 3.20.3, 3.19.6, 3.16.3; com.google.protobuf:protobuf-javalite 3.21.7, 3.20.3, 3.16.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-g5ww-5jh7-63cx lists affected ranges: Maven com.google.protobuf:protobuf-java >=3.17.0 =3.20.0 =3.21.0 =3.0.0 =3.20.0 =3.21.0 =3.0.0 <3.16.3

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-3509: 0.97% estimated exploitation activity in the next 30 days; percentile 61.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A parsing issue similar to CVE-2022-3171, but with textformat in protobuf-java core and lite versions prior to 3.21.7, 3.20.3, 3.19.6 and 3.16.3 can lead to a denial of service attack. Inputs containing multiple instances of non-repeated embedded messages with repeated or unknown fields causes objects to be converted back-n-forth between mutable and immutable forms, resulting in potentially long garbage collection pauses. We recommend updating to the versions mentioned above.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-g5ww-5jh7-63cx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-3509

Advisory: Protobuf Java vulnerable to Uncontrolled Resource Consumption
IDs: CVE-2022-3509, GHSA-g5ww-5jh7-63cx
Record: https://patchnext.com/advisories/cve-2022-3509 (revision 1, source checked 26 Oct 2026, 16:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: com.google.protobuf:protobuf-java 3.21.7, 3.20.3, 3.19.6, 3.16.3; com.google.protobuf:protobuf-javalite 3.21.7, 3.20.3, 3.16.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven com.google.protobuf:protobuf-java: affected >= 3.17.0, < 3.19.6; >= 3.20.0, < 3.20.3; >= 3.21.0, < 3.21.7; >= 3.0.0, < 3.16.3; fixed in 3.21.7, 3.16.3, 3.19.6, 3.20.3
- Maven com.google.protobuf:protobuf-javalite: affected >= 3.20.0, < 3.20.3; >= 3.21.0, < 3.21.7; >= 3.0.0, < 3.16.3; fixed in 3.21.7, 3.16.3, 3.20.3

## Suggested inspection (read-only)
- Maven com.google.protobuf:protobuf-java: check the installed version with your package manager.
- Maven com.google.protobuf:protobuf-javalite: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on com.google.protobuf:protobuf-java, com.google.protobuf:protobuf-javalite.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-g5ww-5jh7-63cx (GitHub-reviewed advisory GHSA-g5ww-5jh7-63cx lists affected ranges: Maven com.google.protobuf:protobuf-java >=3.17.0 =3.20.0 =3.21.0 =3.0.0 =3.20.0 =3.21.0 =3.0.0 <3.16.3)

Commands are suggestions: review each one before running it.

Loading voting…