PYSEC-2022-43166
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (scu-captcha 0.0.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI scu-captcha
- Affected
- >= 0.0.1, < 0.0.5
- Fixed in
- 0.0.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2022-43166 lists affected ranges: PyPI scu-captcha >=0.0.1 <0.0.5 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-34983: 1.68% estimated exploitation activity in the next 30 days; percentile 76.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The scu-captcha package in PyPI v0.0.1 to v0.0.4 included a code execution backdoor inserted by a third party.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from osv record PYSEC-2022-43166
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-34983 Advisory: PYSEC-2022-43166 IDs: CVE-2022-34983 Record: https://patchnext.com/advisories/cve-2022-34983 (revision 1, source checked 24 Oct 2026, 04:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: scu-captcha 0.0.5. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI scu-captcha: affected >= 0.0.1, < 0.0.5; fixed in 0.0.5 ## Suggested inspection (read-only) - `python -m pip show scu-captcha`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on scu-captcha. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/PYSEC-2022-43166 (OSV record PYSEC-2022-43166 lists affected ranges: PyPI scu-captcha >=0.0.1 <0.0.5 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…