Skip to content

← Actionable
Critical, CVSS 9.8amended

NVFLARE unsafe deserialization due to Pickle

CVE-2022-34668GHSA-6qv6-q77g-7qm6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nvflare 2.1.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI nvflare

    Affected
    < 2.1.4
    Fixed in
    2.1.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-34668: 11.61% estimated exploitation activity in the next 30 days; percentile 96.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact NVFLARE contains a vulnerability where deserialization of Untrusted Data due to Pickle usage may allow an unprivileged network attacker to cause Remote Code Execution, Denial Of Service, and Impact to both Confidentiality and Integrity. All versions before 2.1.4 are affected. CVSS Score = 9.8 AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H Patches The patch is included in nvflare==2.1.4 This new version uses MessagePack instead of Pickle to do serialization and deserialization. Some object serializations supported by Pickle are not supported by MessagePack. We have provided out of box support for some built-in NVFLARE objects. For object serializations unsupported by MessagePack, the user will need to convert the objects to numpy or bytes before sending over to remote machines. The list of supported object types are listed in https://github.com/NVIDIA/NVFlare/blob/2.1/nvflare/fuel/utils/fobs/README.rst Workarounds No workarounds available. Additional information Issue Found by: Oliver…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-6qv6-q77g-7qm6

  2. Revision 1 · created ·

    Published from osv record GHSA-6qv6-q77g-7qm6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-34668

Advisory: NVFLARE unsafe deserialization due to Pickle
IDs: CVE-2022-34668, GHSA-6qv6-q77g-7qm6
Record: https://patchnext.com/advisories/cve-2022-34668 (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nvflare 2.1.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI nvflare: affected < 2.1.4; fixed in 2.1.4

## Suggested inspection (read-only)
- `python -m pip show nvflare`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nvflare.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6qv6-q77g-7qm6 (OSV record GHSA-6qv6-q77g-7qm6 lists affected ranges: PyPI nvflare >=0 <2.1.4 (fixed))
- Verified: https://github.com/advisories/GHSA-6qv6-q77g-7qm6 (GitHub-reviewed advisory GHSA-6qv6-q77g-7qm6 lists affected ranges: PyPI nvflare >=0 <2.1.4)

Commands are suggestions: review each one before running it.

Loading voting…