Skip to content

← Actionable
Medium, CVSS 6.1

Cross-site Scripting in Apache Tomcat

CVE-2022-34305GHSA-6j88-6whg-x687

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat:tomcat 10.1.0-M17, 10.0.22, 9.0.65, 8.5.82), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.apache.tomcat:tomcat

    Affected
    >= 10.1.0-M1, <= 10.1.0-M16>= 10.0.0-M1, < 10.0.22>= 9.0.30, < 9.0.65>= 8.5.50, < 8.5.82
    Fixed in
    8.5.82, 9.0.65, 10.1.0-M17, 10.0.22

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2022-34305: 6.71% estimated exploitation activity in the next 30 days; percentile 93.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In Apache Tomcat 10.1.0-M1 to 10.1.0-M16, 10.0.0-M1 to 10.0.22, 9.0.30 to 9.0.64 and 8.5.50 to 8.5.81 the Form authentication example in the examples web application displayed user provided data without filtering, exposing a XSS vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6j88-6whg-x687

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-34305

Advisory: Cross-site Scripting in Apache Tomcat
IDs: CVE-2022-34305, GHSA-6j88-6whg-x687
Record: https://patchnext.com/advisories/cve-2022-34305 (revision 1, source checked 26 Oct 2026, 16:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat:tomcat 10.1.0-M17, 10.0.22, 9.0.65, 8.5.82. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.tomcat:tomcat: affected >= 10.1.0-M1, <= 10.1.0-M16; >= 10.0.0-M1, < 10.0.22; >= 9.0.30, < 9.0.65; >= 8.5.50, < 8.5.82; fixed in 8.5.82, 9.0.65, 10.1.0-M17, 10.0.22

## Suggested inspection (read-only)
- Maven org.apache.tomcat:tomcat: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.tomcat:tomcat.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6j88-6whg-x687 (GitHub-reviewed advisory GHSA-6j88-6whg-x687 lists affected ranges: Maven org.apache.tomcat:tomcat >=10.1.0-M1 =10.0.0-M1 =9.0.30 =8.5.50 <8.5.82)

Commands are suggestions: review each one before running it.

Loading voting…