Skip to content

← Actionable
Medium, CVSS 5.3

Magento Improper Access Control vulnerability

CVE-2022-34259GHSA-9wjf-94h3-r4rh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (magento/community-edition 2.4.5, 2.4.3-p3, 2.3.7-p4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist magento/community-edition

    Affected
    >= 2.3.0, < 2.3.7-p4>= 2.4.4, < 2.4.5>= 2.4.0, < 2.4.3-p3
    Fixed in
    2.4.5, 2.4.3-p3, 2.3.7-p4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2022-34259: 1.66% estimated exploitation activity in the next 30 days; percentile 76.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Access Control vulnerability that could result in a Security feature bypass. An attacker could leverage this vulnerability to impact the availability of a user's minor feature. Exploitation of this issue does not require user interaction.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9wjf-94h3-r4rh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-34259

Advisory: Magento Improper Access Control vulnerability
IDs: CVE-2022-34259, GHSA-9wjf-94h3-r4rh
Record: https://patchnext.com/advisories/cve-2022-34259 (revision 1, source checked 26 Oct 2026, 14:14 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: magento/community-edition 2.4.5, 2.4.3-p3, 2.3.7-p4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist magento/community-edition: affected >= 2.3.0, < 2.3.7-p4; >= 2.4.4, < 2.4.5; >= 2.4.0, < 2.4.3-p3; fixed in 2.4.5, 2.4.3-p3, 2.3.7-p4

## Suggested inspection (read-only)
- Packagist magento/community-edition: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on magento/community-edition.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9wjf-94h3-r4rh (GitHub-reviewed advisory GHSA-9wjf-94h3-r4rh lists affected ranges: Packagist magento/community-edition >=2.3.0 =2.4.4 =2.4.0 <2.4.3-p3)

Commands are suggestions: review each one before running it.

Loading voting…