Magento Path Traversal vulnerability
CVE-2022-34254GHSA-fx9g-g9q6-x3jx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (magento/community-edition 2.4.5, 2.4.3-p3, 2.3.7-p4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist magento/community-edition
- Affected
- >= 2.3.0, < 2.3.7-p4>= 2.4.0, < 2.4.3-p3>= 2.4.4, <= 2.4.4
- Fixed in
- 2.4.5, 2.4.3-p3, 2.3.7-p4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fx9g-g9q6-x3jx lists affected ranges: Packagist magento/community-edition >=2.3.0 =2.4.0 =2.4.4 <=2.4.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
- EPSS
- CVE-2022-34254: 2.33% estimated exploitation activity in the next 30 days; percentile 83.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability that could be abused by an attacker to inject malicious scripts into the vulnerable endpoint. A low privileged attacker could leverage this vulnerability to read local files and to perform Stored XSS. Exploitation of this issue does not require user interaction.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fx9g-g9q6-x3jx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-34254 Advisory: Magento Path Traversal vulnerability IDs: CVE-2022-34254, GHSA-fx9g-g9q6-x3jx Record: https://patchnext.com/advisories/cve-2022-34254 (revision 1, source checked 26 Oct 2026, 14:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: magento/community-edition 2.4.5, 2.4.3-p3, 2.3.7-p4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist magento/community-edition: affected >= 2.3.0, < 2.3.7-p4; >= 2.4.0, < 2.4.3-p3; >= 2.4.4, <= 2.4.4; fixed in 2.4.5, 2.4.3-p3, 2.3.7-p4 ## Suggested inspection (read-only) - Packagist magento/community-edition: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on magento/community-edition. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fx9g-g9q6-x3jx (GitHub-reviewed advisory GHSA-fx9g-g9q6-x3jx lists affected ranges: Packagist magento/community-edition >=2.3.0 =2.4.0 =2.4.4 <=2.4.4) Commands are suggestions: review each one before running it.
Loading voting…