Skip to content

← Actionable
High, CVSS 7.5

Apache Xalan Java XSLT library integer truncation issue when processing malicious XSLT stylesheets

CVE-2022-34169GHSA-9339-86wc-4qgf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (xalan:xalan 2.7.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2022-34169: 81.76% estimated exploitation activity in the next 30 days; percentile 99.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The Apache Xalan Java XSLT library is vulnerable to an integer truncation issue when processing malicious XSLT stylesheets. This can be used to corrupt Java class files generated by the internal XSLTC compiler and execute arbitrary Java bytecode. A fix for this issue was published in September 2022 as part of an anticipated 2.7.3 release.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9339-86wc-4qgf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-34169

Advisory: Apache Xalan Java XSLT library integer truncation issue when processing malicious XSLT stylesheets
IDs: CVE-2022-34169, GHSA-9339-86wc-4qgf
Record: https://patchnext.com/advisories/cve-2022-34169 (revision 1, source checked 26 Oct 2026, 16:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: xalan:xalan 2.7.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven xalan:xalan: affected < 2.7.3; fixed in 2.7.3

## Suggested inspection (read-only)
- Maven xalan:xalan: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on xalan:xalan.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9339-86wc-4qgf (GitHub-reviewed advisory GHSA-9339-86wc-4qgf lists affected ranges: Maven xalan:xalan >=0 <2.7.3)

Commands are suggestions: review each one before running it.

Loading voting…