Apache JSPWiki CSRF due to crafted invocation on the Image plugin
CVE-2022-34158GHSA-jp3m-p26h-mm7v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.jspwiki:jspwiki-main 2.11.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.jspwiki:jspwiki-main
- Affected
- < 2.11.3
- Fixed in
- 2.11.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jp3m-p26h-mm7v lists affected ranges: Maven org.apache.jspwiki:jspwiki-main >=0 <2.11.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-34158: 1.28% estimated exploitation activity in the next 30 days; percentile 69.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A carefully crafted invocation on the Image plugin could trigger an CSRF vulnerability on Apache JSPWiki before 2.11.3, which could allow a group privilege escalation of the attacker's account. Further examination of this issue established that it could also be used to modify the email associated with the attacked account, and then a reset password request from the login page.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jp3m-p26h-mm7v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-34158 Advisory: Apache JSPWiki CSRF due to crafted invocation on the Image plugin IDs: CVE-2022-34158, GHSA-jp3m-p26h-mm7v Record: https://patchnext.com/advisories/cve-2022-34158 (revision 1, source checked 26 Oct 2026, 16:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.jspwiki:jspwiki-main 2.11.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.jspwiki:jspwiki-main: affected < 2.11.3; fixed in 2.11.3 ## Suggested inspection (read-only) - Maven org.apache.jspwiki:jspwiki-main: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.jspwiki:jspwiki-main. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jp3m-p26h-mm7v (GitHub-reviewed advisory GHSA-jp3m-p26h-mm7v lists affected ranges: Maven org.apache.jspwiki:jspwiki-main >=0 <2.11.3) Commands are suggestions: review each one before running it.
Loading voting…