Got allows a redirect to a UNIX socket
CVE-2022-33987GHSA-pfrx-2q88-qq97
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (got 12.1.0, 11.8.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm got
- Affected
- >= 12.0.0, < 12.1.0< 11.8.5
- Fixed in
- 11.8.5, 12.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pfrx-2q88-qq97 lists affected ranges: npm got >=12.0.0 =0 <11.8.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pfrx-2q88-qq97 lists affected ranges: npm got >=12.0.0 =0 <11.8.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2022-33987: 2.42% estimated exploitation activity in the next 30 days; percentile 84.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The got package before 11.8.5 and 12.1.0 for Node.js allows a redirect to a UNIX socket.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-pfrx-2q88-qq97
- Revision 1 · created ·
Published from osv record GHSA-pfrx-2q88-qq97
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-33987 Advisory: Got allows a redirect to a UNIX socket IDs: CVE-2022-33987, GHSA-pfrx-2q88-qq97 Record: https://patchnext.com/advisories/cve-2022-33987 (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: got 12.1.0, 11.8.5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm got: affected >= 12.0.0, < 12.1.0; < 11.8.5; fixed in 11.8.5, 12.1.0 ## Suggested inspection (read-only) - `npm ls got --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on got. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pfrx-2q88-qq97 (OSV record GHSA-pfrx-2q88-qq97 lists affected ranges: npm got >=12.0.0 =0 <11.8.5 (fixed)) - Verified: https://github.com/advisories/GHSA-pfrx-2q88-qq97 (GitHub-reviewed advisory GHSA-pfrx-2q88-qq97 lists affected ranges: npm got >=12.0.0 =0 <11.8.5) Commands are suggestions: review each one before running it.
Loading voting…