Apache Spark UI can allow impersonation if ACLs enabled
CVE-2022-33891GHSA-4x9r-j582-cgr8
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.spark:spark-parent_2.12
- Affected
- <= 3.0.3>= 3.1.1, < 3.2.2
- Fixed in
- 3.2.2
PyPI pyspark
- Affected
- < 3.1.3>= 3.2.0, < 3.2.2
- Fixed in
- 3.1.3, 3.2.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4x9r-j582-cgr8 lists affected ranges: Maven org.apache.spark:spark-parent_2.12 >=0 =3.1.1 =0 =3.2.0 <3.2.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- CISA Known Exploited Vulnerabilities Catalog
CISA added CVE-2022-33891 to the Known Exploited Vulnerabilities catalog on 2023-03-07.
VerifiedObserved Listed in the CISA KEV JSON feed; separate from customer applicability.
- CISA Known Exploited Vulnerabilities Catalog
CISA added CVE-2022-33891 to the Known Exploited Vulnerabilities catalog on 2023-03-07.
VerifiedObserved Listed in the CISA KEV JSON feed (dateAdded 2023-03-07).
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4x9r-j582-cgr8 lists affected ranges: Maven org.apache.spark:spark-parent_2.12 >=0 =3.1.1 =0 =3.2.0 <3.2.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:N/E:A · score source
- EPSS
- CVE-2022-33891: 93.24% estimated exploitation activity in the next 30 days; percentile 99.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The Apache Spark UI offers the possibility to enable ACLs via the configuration option spark.acls.enable. With an authentication filter, this checks whether a user has access permissions to view or modify the application. If ACLs are enabled, a code path in HttpSecurityFilter can allow someone to perform impersonation by providing an arbitrary user name. A malicious user might then be able to reach a permission check function that will ultimately build a Unix shell command based on their input, and execute it. This will result in arbitrary shell command execution as the user Spark is currently running as. This affects Apache Spark versions 3.0.3 and earlier, versions 3.1.1 to 3.1.2, and versions 3.2.0 to 3.2.1. A previous version of this advisory incorrectly stated that version 3.1.3 was not vulnerable. Per GHSA-59hw-j9g6-mfg3, version 3.1.3 is vulnerable and vulnerable version ranges in this advisory have been changed to reflect the correct information.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-4x9r-j582-cgr8
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · evidence added ·
CISA KEV confirmed exploitation for CVE-2022-33891 (date added 2023-03-07). Customer workflow unchanged.
- Revision 1 · created ·
Published from osv record GHSA-4x9r-j582-cgr8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-33891 Advisory: Apache Spark UI can allow impersonation if ACLs enabled IDs: CVE-2022-33891, GHSA-4x9r-j582-cgr8 Record: https://patchnext.com/advisories/cve-2022-33891 (revision 4, source checked 26 Oct 2026, 13:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog. Vendor response: Partial vendor fix; fixed versions by package: org.apache.spark:spark-parent_2.12 3.2.2; pyspark 3.2.2, 3.1.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.spark:spark-parent_2.12: affected <= 3.0.3; >= 3.1.1, < 3.2.2; fixed in 3.2.2 - PyPI pyspark: affected < 3.1.3; >= 3.2.0, < 3.2.2; fixed in 3.1.3, 3.2.2 ## Suggested inspection (read-only) - Maven org.apache.spark:spark-parent_2.12: check the installed version with your package manager. - `python -m pip show pyspark`: prints the installed version. Run with the environment that serves production active. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.spark:spark-parent_2.12, pyspark. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4x9r-j582-cgr8 (OSV record GHSA-4x9r-j582-cgr8 lists affected ranges: Maven org.apache.spark:spark-parent_2.12 >=0 =3.1.1 =0 =3.2.0 <3.2.2 (fixed)) - Verified: https://www.cisa.gov/sites/default/files/feeds/known_exploited_vulnerabilities.json (CISA added CVE-2022-33891 to the Known Exploited Vulnerabilities catalog on 2023-03-07.) - Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2022-33891 to the Known Exploited Vulnerabilities catalog on 2023-03-07.) - Verified: https://github.com/advisories/GHSA-4x9r-j582-cgr8 (GitHub-reviewed advisory GHSA-4x9r-j582-cgr8 lists affected ranges: Maven org.apache.spark:spark-parent_2.12 >=0 =3.1.1 =0 =3.2.0 <3.2.2) Commands are suggestions: review each one before running it.
Loading voting…