Apache Pulsar Disabled Certificate Validation for OAuth Client Credential Requests makes C++/Python Clients vulnerable to MITM attack
CVE-2022-33684GHSA-5r3h-c3r7-9w4h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pulsar-client 2.10.2, 2.9.3, 2.8.4, 2.7.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pulsar-client
- Affected
- < 2.7.5>= 2.8.0, < 2.8.4>= 2.9.0, < 2.9.3>= 2.10.0, < 2.10.2
- Fixed in
- 2.10.2, 2.9.3, 2.7.5, 2.8.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5r3h-c3r7-9w4h lists affected ranges: PyPI pulsar-client >=0 =2.8.0 =2.9.0 =2.10.0 <2.10.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5r3h-c3r7-9w4h lists affected ranges: PyPI pulsar-client >=0 =2.8.0 =2.9.0 =2.10.0 <2.10.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-33684: 0.93% estimated exploitation activity in the next 30 days; percentile 60.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The Apache Pulsar C++ Client does not verify peer TLS certificates when making HTTPS calls for the OAuth2.0 Client Credential Flow, even when tlsAllowInsecureConnection is disabled via configuration. This vulnerability allows an attacker to perform a man in the middle attack and intercept and/or modify the GET request that is sent to the ClientCredentialFlow "issuer url". The intercepted credentials can be used to acquire authentication data from the OAuth2.0 server to then authenticate with an Apache Pulsar cluster. An attacker can only take advantage of this vulnerability by taking control of a machine "between" the client and the server. The attacker must then actively manipulate traffic to perform the attack. The Apache Pulsar Python Client wraps the C++ client, so it is also vulnerable in the same way. This issue affects Apache Pulsar C++ Client and Python Client versions 2.7.0 to 2.7.4; 2.8.0 to 2.8.3; 2.9.0 to 2.9.2; 2.10.0 to 2.10.1; 2.6.4 and earlier. Any users running…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-5r3h-c3r7-9w4h
- Revision 1 · created ·
Published from osv record GHSA-5r3h-c3r7-9w4h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-33684 Advisory: Apache Pulsar Disabled Certificate Validation for OAuth Client Credential Requests makes C++/Python Clients vulnerable to MITM attack IDs: CVE-2022-33684, GHSA-5r3h-c3r7-9w4h Record: https://patchnext.com/advisories/cve-2022-33684 (revision 2, source checked 26 Oct 2026, 13:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pulsar-client 2.10.2, 2.9.3, 2.8.4, 2.7.5. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pulsar-client: affected < 2.7.5; >= 2.8.0, < 2.8.4; >= 2.9.0, < 2.9.3; >= 2.10.0, < 2.10.2; fixed in 2.10.2, 2.9.3, 2.7.5, 2.8.4 ## Suggested inspection (read-only) - `python -m pip show pulsar-client`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pulsar-client. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5r3h-c3r7-9w4h (OSV record GHSA-5r3h-c3r7-9w4h lists affected ranges: PyPI pulsar-client >=0 =2.8.0 =2.9.0 =2.10.0 <2.10.2 (fixed)) - Verified: https://github.com/advisories/GHSA-5r3h-c3r7-9w4h (GitHub-reviewed advisory GHSA-5r3h-c3r7-9w4h lists affected ranges: PyPI pulsar-client >=0 =2.8.0 =2.9.0 =2.10.0 <2.10.2) Commands are suggestions: review each one before running it.
Loading voting…