PYSEC-2022-217
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (cryptoasset-data-downloader 1.0.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI cryptoasset-data-downloader
- Affected
- >= 1.0.0, < 1.0.2
- Fixed in
- 1.0.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2022-217 lists affected ranges: PyPI cryptoasset-data-downloader >=1.0.0 <1.0.2 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2022-32998: 2.00% estimated exploitation activity in the next 30 days; percentile 80.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The cryptoasset-data-downloader package in PyPI v1.0.0 to v1.0.1 was discovered to contain a code execution backdoor via the request package. This vulnerability allows attackers to access sensitive user information and digital currency keys, as well as escalate privileges.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from osv record PYSEC-2022-217
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-32998 Advisory: PYSEC-2022-217 IDs: CVE-2022-32998 Record: https://patchnext.com/advisories/cve-2022-32998 (revision 1, source checked 24 Oct 2026, 04:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: cryptoasset-data-downloader 1.0.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI cryptoasset-data-downloader: affected >= 1.0.0, < 1.0.2; fixed in 1.0.2 ## Suggested inspection (read-only) - `python -m pip show cryptoasset-data-downloader`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on cryptoasset-data-downloader. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/PYSEC-2022-217 (OSV record PYSEC-2022-217 lists affected ranges: PyPI cryptoasset-data-downloader >=1.0.0 <1.0.2 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…