Skip to content

← Actionable
High, CVSS 7.5amended

rdiffweb vulnerable to potential DoS via memory consumption

CVE-2022-3298GHSA-xhw9-4wqq-x67v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (rdiffweb 2.4.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI rdiffweb

    Affected
    < 2.4.8
    Fixed in
    2.4.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-3298: 1.16% estimated exploitation activity in the next 30 days; percentile 67.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

rdiffweb prior to 2.4.8 is vulnerable to a potential Dos attack via an unlimited length "title" field when adding an SSH key. This can result in excess memory consumption, leading to a Denial of Service (DoS). This issue is patched in version 2.4.8. There are no known workarounds.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-xhw9-4wqq-x67v

  2. Revision 1 · created ·

    Published from osv record GHSA-xhw9-4wqq-x67v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-3298

Advisory: rdiffweb vulnerable to potential DoS via memory consumption
IDs: CVE-2022-3298, GHSA-xhw9-4wqq-x67v
Record: https://patchnext.com/advisories/cve-2022-3298 (revision 2, source checked 26 Oct 2026, 13:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: rdiffweb 2.4.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI rdiffweb: affected < 2.4.8; fixed in 2.4.8

## Suggested inspection (read-only)
- `python -m pip show rdiffweb`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on rdiffweb.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xhw9-4wqq-x67v (OSV record GHSA-xhw9-4wqq-x67v lists affected ranges: PyPI rdiffweb >=0 <2.4.8 (fixed))
- Verified: https://github.com/advisories/GHSA-xhw9-4wqq-x67v (GitHub-reviewed advisory GHSA-xhw9-4wqq-x67v lists affected ranges: PyPI rdiffweb >=0 <2.4.8)

Commands are suggestions: review each one before running it.

Loading voting…