Kubernetes vulnerable to validation bypass
CVE-2022-3294GHSA-jh36-q97c-9928
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/kubernetes/kubernetes 1.25.4, 1.24.8, 1.23.14, 1.22.16), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/kubernetes/kubernetes
- Affected
- >= 1.25.0, < 1.25.4>= 1.22.0, < 1.22.16>= 1.24.0, < 1.24.8>= 1.23.0, < 1.23.14
- Fixed in
- 1.25.4, 1.24.8, 1.23.14, 1.22.16
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jh36-q97c-9928 lists affected ranges: Go github.com/kubernetes/kubernetes >=1.25.0 =1.22.0 =1.24.0 =1.23.0 <1.23.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-3294: 1.62% estimated exploitation activity in the next 30 days; percentile 76.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Users may have access to secure endpoints in the control plane network. Kubernetes clusters are only affected if an untrusted user can modify Node objects and send proxy requests to them. Kubernetes supports node proxying, which allows clients of kube-apiserver to access endpoints of a Kubelet to establish connections to Pods, retrieve container logs, and more. While Kubernetes already validates the proxying address for Nodes, a bug in kube-apiserver made it possible to bypass this validation. Bypassing this validation could allow authenticated requests destined for Nodes to to the API server's private network.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jh36-q97c-9928
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-3294 Advisory: Kubernetes vulnerable to validation bypass IDs: CVE-2022-3294, GHSA-jh36-q97c-9928 Record: https://patchnext.com/advisories/cve-2022-3294 (revision 1, source checked 26 Oct 2026, 14:58 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/kubernetes/kubernetes 1.25.4, 1.24.8, 1.23.14, 1.22.16. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/kubernetes/kubernetes: affected >= 1.25.0, < 1.25.4; >= 1.22.0, < 1.22.16; >= 1.24.0, < 1.24.8; >= 1.23.0, < 1.23.14; fixed in 1.25.4, 1.24.8, 1.23.14, 1.22.16 ## Suggested inspection (read-only) - Go github.com/kubernetes/kubernetes: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/kubernetes/kubernetes. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jh36-q97c-9928 (GitHub-reviewed advisory GHSA-jh36-q97c-9928 lists affected ranges: Go github.com/kubernetes/kubernetes >=1.25.0 =1.22.0 =1.24.0 =1.23.0 <1.23.14) Commands are suggestions: review each one before running it.
Loading voting…