Skip to content

← Actionable
Critical, CVSS 9.3amended

Couchbase Sync Gateway admin credentials not verified when using X.509 client cert authentication

CVE-2022-32563GHSA-9266-j9v3-q4j5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (couchbase 3.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI couchbase

    Affected
    >= 3.0.0, < 3.0.2
    Fixed in
    3.0.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2022-32563: 0.84% estimated exploitation activity in the next 30 days; percentile 57.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An issue was discovered in Couchbase Sync Gateway 3.x before 3.0.2. Admin credentials are not verified when using X.509 client-certificate authentication from Sync Gateway to Couchbase Server. When Sync Gateway is configured to authenticate with Couchbase Server using X.509 client certificates, the admin credentials provided to the Admin REST API are ignored, resulting in privilege escalation for unauthenticated users. The Public REST API is not impacted by this issue. A workaround is to replace X.509 certificate based authentication with Username and Password authentication inside the bootstrap configuration.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-9266-j9v3-q4j5

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-9266-j9v3-q4j5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-32563

Advisory: Couchbase Sync Gateway admin credentials not verified when using X.509 client cert authentication
IDs: CVE-2022-32563, GHSA-9266-j9v3-q4j5
Record: https://patchnext.com/advisories/cve-2022-32563 (revision 3, source checked 26 Oct 2026, 13:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: couchbase 3.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI couchbase: affected >= 3.0.0, < 3.0.2; fixed in 3.0.2

## Suggested inspection (read-only)
- `python -m pip show couchbase`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on couchbase.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9266-j9v3-q4j5 (OSV record GHSA-9266-j9v3-q4j5 lists affected ranges: PyPI couchbase >=3.0.0 <3.0.2 (fixed))
- Verified: https://github.com/advisories/GHSA-9266-j9v3-q4j5 (GitHub-reviewed advisory GHSA-9266-j9v3-q4j5 lists affected ranges: PyPI couchbase >=3.0.0 <3.0.2)

Commands are suggestions: review each one before running it.

Loading voting…