Skip to content

← Actionable
Critical, CVSS 9.8

Active Record RCE bug with Serialized Columns

CVE-2022-32224GHSA-3hhc-qp5v-9p2j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (activerecord 7.0.3.1, 6.1.6.1, 6.0.5.1, 5.2.8.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems activerecord

    Affected
    >= 7.0.0, <= 7.0.3>= 6.1.0, <= 6.1.6>= 6.0.0, <= 6.0.5<= 5.2.8
    Fixed in
    7.0.3.1, 6.1.6.1, 5.2.8.1, 6.0.5.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-32224: 2.60% estimated exploitation activity in the next 30 days; percentile 85.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

When serialized columns that use YAML (the default) are deserialized, Rails uses YAML.unsafeload to convert the YAML data in to Ruby objects. If an attacker can manipulate data in the database (via means like SQL injection), then it may be possible for the attacker to escalate to an RCE. There are no feasible workarounds for this issue, but other coders (such as JSON) are not impacted.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3hhc-qp5v-9p2j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-32224

Advisory: Active Record RCE bug with Serialized Columns
IDs: CVE-2022-32224, GHSA-3hhc-qp5v-9p2j
Record: https://patchnext.com/advisories/cve-2022-32224 (revision 1, source checked 26 Oct 2026, 15:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: activerecord 7.0.3.1, 6.1.6.1, 6.0.5.1, 5.2.8.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems activerecord: affected >= 7.0.0, <= 7.0.3; >= 6.1.0, <= 6.1.6; >= 6.0.0, <= 6.0.5; <= 5.2.8; fixed in 7.0.3.1, 6.1.6.1, 5.2.8.1, 6.0.5.1

## Suggested inspection (read-only)
- RubyGems activerecord: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on activerecord.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3hhc-qp5v-9p2j (GitHub-reviewed advisory GHSA-3hhc-qp5v-9p2j lists affected ranges: RubyGems activerecord >=7.0.0 =6.1.0 =6.0.0 =0 <=5.2.8)

Commands are suggestions: review each one before running it.

Loading voting…