llhttp allows HTTP Request Smuggling via Improper Delimiting of Header Fields
CVE-2022-32214GHSA-q5vx-44v4-gch4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (node 18.5.0, 16.20.0, 14.20.0; llhttp 6.0.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
runtime node
- Affected
- >= 14.0.0, < 14.20.0>= 16.0.0, < 16.20.0>= 18.0.0, < 18.5.0
- Fixed in
- 14.20.0, 18.5.0, 16.20.0
npm llhttp
- Affected
- < 6.0.7
- Fixed in
- 6.0.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q5vx-44v4-gch4 lists affected ranges: npm llhttp >=0 <6.0.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q5vx-44v4-gch4 lists affected ranges: npm llhttp >=0 <6.0.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- nodejs.org runtime security intelligence
The nodejs.org release index dates the first patched release for CVE-2022-32214 to 2022-07-06.
VerifiedObserved Official nodejs.org release index (dist/index.json).
- raw.githubusercontent.com runtime security intelligence
Node.js security working group core entry 95 lists CVE-2022-32214 affecting node >=14.0.0 =16.0.0 =18.0.0 <18.5.0
VerifiedObserved Authoritative source for Node.js core CVEs: structured Node.js security-wg core vulnerability record maintained by the Node.js project.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2022-32214: 81.83% estimated exploitation activity in the next 30 days; percentile 99.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The llhttp parser in the http module in Node.js does not strictly use the CRLF sequence to delimit HTTP requests. The LF character (without CR) is sufficient to delimit HTTP header fields in the lihttp parser. According to RFC7230 section 3, only the CRLF sequence should delimit each header-field. This can lead to HTTP Request Smuggling (HRS).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from vendor_advisory record nodejs-security-wg:core:95
- Revision 2 · amended ·
Amended from ghsa record GHSA-q5vx-44v4-gch4
- Revision 1 · created ·
Published from osv record GHSA-q5vx-44v4-gch4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-32214 Advisory: llhttp allows HTTP Request Smuggling via Improper Delimiting of Header Fields IDs: CVE-2022-32214, GHSA-q5vx-44v4-gch4 Record: https://patchnext.com/advisories/cve-2022-32214 (revision 3, source checked 26 Oct 2026, 16:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: node 18.5.0, 16.20.0, 14.20.0; llhttp 6.0.7. A vendor fix does not mean a deployment is fixed. ## Affected components - runtime node: affected >= 14.0.0, < 14.20.0; >= 16.0.0, < 16.20.0; >= 18.0.0, < 18.5.0; fixed in 14.20.0, 18.5.0, 16.20.0 - npm llhttp: affected < 6.0.7; fixed in 6.0.7 ## Suggested inspection (read-only) - runtime node: check the installed version with your package manager. - `npm ls llhttp --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on node, llhttp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q5vx-44v4-gch4 (OSV record GHSA-q5vx-44v4-gch4 lists affected ranges: npm llhttp >=0 <6.0.7 (fixed)) - Verified: https://github.com/advisories/GHSA-q5vx-44v4-gch4 (GitHub-reviewed advisory GHSA-q5vx-44v4-gch4 lists affected ranges: npm llhttp >=0 <6.0.7) - Verified: https://nodejs.org/dist/index.json (The nodejs.org release index dates the first patched release for CVE-2022-32214 to 2022-07-06.) - Verified: https://raw.githubusercontent.com/nodejs/security-wg/main/vuln/core/95.json (Node.js security working group core entry 95 lists CVE-2022-32214 affecting node >=14.0.0 =16.0.0 =18.0.0 <18.5.0) Commands are suggestions: review each one before running it.
Loading voting…