Skip to content

← Actionable
Critical, CVSS 9.1amended

llhttp allows HTTP Request Smuggling via Flawed Parsing of Transfer-Encoding

CVE-2022-32213GHSA-5689-v88g-g6rv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (node 18.9.1, 16.17.1, 14.20.1; llhttp 6.0.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • runtime node

    Affected
    >= 14.0.0, < 14.20.1>= 16.0.0, < 16.17.1>= 18.0.0, < 18.9.1
    Fixed in
    18.9.1, 14.20.1, 16.17.1
  • npm llhttp

    Affected
    < 6.0.7
    Fixed in
    6.0.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2022-32213: 44.84% estimated exploitation activity in the next 30 days; percentile 98.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The llhttp parser in the http module in Node.js v17.x does not correctly parse and validate Transfer-Encoding headers and can lead to HTTP Request Smuggling (HRS). Impacts: - All versions of the nodejs 18.x, 16.x, and 14.x releases lines. - llhttp v6.0.7 and llhttp v2.1.5 contains the fixes that were updated inside Node.js

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from vendor_advisory record nodejs-security-wg:core:97

  2. Revision 2 · amended ·

    Amended from ghsa record GHSA-5689-v88g-g6rv

  3. Revision 1 · created ·

    Published from osv record GHSA-5689-v88g-g6rv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-32213

Advisory: llhttp allows HTTP Request Smuggling via Flawed Parsing of Transfer-Encoding
IDs: CVE-2022-32213, GHSA-5689-v88g-g6rv
Record: https://patchnext.com/advisories/cve-2022-32213 (revision 3, source checked 26 Oct 2026, 16:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: node 18.9.1, 16.17.1, 14.20.1; llhttp 6.0.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- runtime node: affected >= 14.0.0, < 14.20.1; >= 16.0.0, < 16.17.1; >= 18.0.0, < 18.9.1; fixed in 18.9.1, 14.20.1, 16.17.1
- npm llhttp: affected < 6.0.7; fixed in 6.0.7

## Suggested inspection (read-only)
- runtime node: check the installed version with your package manager.
- `npm ls llhttp --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on node, llhttp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5689-v88g-g6rv (OSV record GHSA-5689-v88g-g6rv lists affected ranges: npm llhttp >=0 <6.0.7 (fixed))
- Verified: https://github.com/advisories/GHSA-5689-v88g-g6rv (GitHub-reviewed advisory GHSA-5689-v88g-g6rv lists affected ranges: npm llhttp >=0 <6.0.7)
- Verified: https://raw.githubusercontent.com/nodejs/security-wg/main/vuln/core/97.json (Node.js security working group core entry 97 lists CVE-2022-32213 affecting node >=14.0.0 =16.0.0 =18.0.0 <18.9.1)
- Verified: https://nodejs.org/dist/index.json (The nodejs.org release index dates the first patched release for CVE-2022-32213 to 2022-09-23.)

Commands are suggestions: review each one before running it.

Loading voting…