Skip to content

← Actionable
High, CVSS 7.7amended

ProxyAgent vulnerable to MITM

CVE-2022-32210GHSA-pgw7-wx7w-2w33

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (undici 5.5.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm undici

    Affected
    >= 4.8.2, <= 5.5.0
    Fixed in
    5.5.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.7 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:N
EPSS
  • CVE-2022-32210: 0.47% estimated exploitation activity in the next 30 days; percentile 40.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description Undici.ProxyAgent never verifies the remote server's certificate, and always exposes all request & response data to the proxy. This unexpectedly means that proxies can MitM all HTTPS traffic, and if the proxy's URL is HTTP then it also means that nominally HTTPS requests are actually sent via plain-text HTTP between Undici and the proxy server. Impact This affects all use of HTTPS via HTTP proxy using Undici.ProxyAgent with Undici or Node's global fetch. In this case, it removes all HTTPS security from all requests sent using Undici's ProxyAgent, allowing trivial MitM attacks by anybody on the network path between the client and the target server (local network users, your ISP, the proxy, the target server's ISP, etc). This less seriously affects HTTPS via HTTPS proxies. When you send HTTPS via a proxy to a remote server, the proxy can freely view or modify all HTTPS traffic unexpectedly (but only the proxy). Patches This issue was patched in Undici v5.5.1. Workarounds At…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-pgw7-wx7w-2w33

  2. Revision 1 · created ·

    Published from osv record GHSA-pgw7-wx7w-2w33

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-32210

Advisory: ProxyAgent vulnerable to MITM
IDs: CVE-2022-32210, GHSA-pgw7-wx7w-2w33
Record: https://patchnext.com/advisories/cve-2022-32210 (revision 2, source checked 26 Oct 2026, 12:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: undici 5.5.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm undici: affected >= 4.8.2, <= 5.5.0; fixed in 5.5.1

## Suggested inspection (read-only)
- `npm ls undici --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on undici.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-pgw7-wx7w-2w33 (OSV record GHSA-pgw7-wx7w-2w33 lists affected ranges: npm undici >=4.8.2 <5.5.1 (fixed))
- Verified: https://github.com/advisories/GHSA-pgw7-wx7w-2w33 (GitHub-reviewed advisory GHSA-pgw7-wx7w-2w33 lists affected ranges: npm undici >=4.8.2 <=5.5.0)

Commands are suggestions: review each one before running it.

Loading voting…