Rails::Html::Sanitizer vulnerable to Cross-site Scripting
CVE-2022-32209GHSA-pg8v-g4xq-hww9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (rails-html-sanitizer 1.4.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems rails-html-sanitizer
- Affected
- < 1.4.3
- Fixed in
- 1.4.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pg8v-g4xq-hww9 lists affected ranges: RubyGems rails-html-sanitizer >=0 <1.4.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2022-32209: 30.23% estimated exploitation activity in the next 30 days; percentile 98.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of Rails::Html::Sanitizer prior to version 1.4.3 are vulnerable to XSS with certain configurations of Rails::Html::Sanitizer which allows an attacker to inject content when the application developer has overridden the sanitizer's allowed tags to allow both select and style elements. Code is only impacted if allowed tags are being overridden. This may be done via application configuration: see https://guides.rubyonrails.org/configuring.html#configuring-action-view Or it may be done with a :tags option to the Action View helper sanitize: see https://api.rubyonrails.org/classes/ActionView/Helpers/SanitizeHelper.html#method-i-sanitize It may also be done with Rails::Html::SafeListSanitizer directly: or with All users overriding the allowed tags by any of the above mechanisms to include both "select" and "style" are recommended to upgrade immediately. A workaround for this issue can be applied by removing either select or style from the overridden allowed tags.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-pg8v-g4xq-hww9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-32209 Advisory: Rails::Html::Sanitizer vulnerable to Cross-site Scripting IDs: CVE-2022-32209, GHSA-pg8v-g4xq-hww9 Record: https://patchnext.com/advisories/cve-2022-32209 (revision 1, source checked 26 Oct 2026, 15:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: rails-html-sanitizer 1.4.3. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems rails-html-sanitizer: affected < 1.4.3; fixed in 1.4.3 ## Suggested inspection (read-only) - RubyGems rails-html-sanitizer: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on rails-html-sanitizer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-pg8v-g4xq-hww9 (GitHub-reviewed advisory GHSA-pg8v-g4xq-hww9 lists affected ranges: RubyGems rails-html-sanitizer >=0 <1.4.3) Commands are suggestions: review each one before running it.
Loading voting…