Cross site scripting in Cloudreve
CVE-2022-32167GHSA-fg25-gq9g-32mx
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/cloudreve/Cloudreve/v3
- Affected
- >= 3.0.0, < 3.6.0-beta1
- Fixed in
- 3.6.0-beta1
Go github.com/HFO4/cloudreve
- Affected
- >= 1.0.0, <= 2.0.0
- Fixed in
- no fixed version recorded
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fg25-gq9g-32mx lists affected ranges: Go github.com/HFO4/cloudreve >=1.0.0 =3.0.0 <3.6.0-beta1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2022-32167: 0.56% estimated exploitation activity in the next 30 days; percentile 46.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Cloudreve versions v1.0.0 through v3.5.3 are vulnerable to Stored Cross-Site Scripting (XSS), via the file upload functionality. A low privileged user will be able to share a file with an admin user, which could lead to privilege escalation.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fg25-gq9g-32mx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-32167 Advisory: Cross site scripting in Cloudreve IDs: CVE-2022-32167, GHSA-fg25-gq9g-32mx Record: https://patchnext.com/advisories/cve-2022-32167 (revision 1, source checked 26 Oct 2026, 14:58 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: github.com/cloudreve/Cloudreve/v3 3.6.0-beta1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/cloudreve/Cloudreve/v3: affected >= 3.0.0, < 3.6.0-beta1; fixed in 3.6.0-beta1 - Go github.com/HFO4/cloudreve: affected >= 1.0.0, <= 2.0.0 ## Suggested inspection (read-only) - Go github.com/cloudreve/Cloudreve/v3: check the installed version with your package manager. - Go github.com/HFO4/cloudreve: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/cloudreve/Cloudreve/v3, github.com/HFO4/cloudreve. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fg25-gq9g-32mx (GitHub-reviewed advisory GHSA-fg25-gq9g-32mx lists affected ranges: Go github.com/HFO4/cloudreve >=1.0.0 =3.0.0 <3.6.0-beta1) Commands are suggestions: review each one before running it.
Loading voting…